Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

[R5] Tenable Products Affected by PHP < 5.5.21 / 5.4.37 Vulnerabilities

Medium

Synopsis

PHP contains a use-after-free error in the process_nested_data() function in ext/standard/var_unserializer.re. With specially crafted input passed to the unserialize() method, a remote attacker can dereference already freed memory and potentially execute arbitrary code. (CVE-2014-8142 / CVE-2015-0231)

PHP contains a flaw in the exif_process_unicode() function in ext/exif/exif.c when parsing JPEG EXIF entries. This may allow a remote attacker to trigger freeing of an uninitialized pointer, causing a crash or potentially execution of arbitrary code. (CVE-2015-0232)

PHP contains a flaw in the main() function in sapi/cgi/cgi_main.c that is triggered when handling input consisting solely of a single "#" character. With a specially crafted PHP file, a remote attacker can cause a crash or potentially disclose memory contents. (CVE-2014-9427)

The process_nested_data() function is used within Tenable's SecurityCenter, but is only exposed to authenticated users. Note that the affiliated CVSSv2 score is specific to the PHP implementation within SecurityCenter and the process_nested_data() issue.

Please note that Tenable strongly recommends that SecurityCenter and the Tenable Appliance be installed on a subnet that is not Internet addressable.

Solution

SecurityCenter

Tenable has released a patch for all supported versions of SecurityCenter that addresses this vulnerability. This patch applies PHP 5.4.37, which is not affected, or modifies PHP 5.3.x as needed to mitigate the issue. The patch can be obtained from:

https://support.tenable.com/support-center/index.php?x=&mod_id=160

PHP Patches for SC 4.8.2:
File	   		      md5sum
SC-201502.2-4.8.2-rh5-32.tgz  0673ac259e90db8d75681af5f04a4c40
SC-201502.2-4.8.2-rh5-64.tgz  8b01972998d0525ec31dfff0ec64c74b
SC-201502.2-4.8.2-rh6-32.tgz  cb8c9c6c4af75c71b909db711bffcc79
SC-201502.2-4.8.2-rh6-64.tgz  61d968c7441c4fcfae02bc17bcc9ad42
PHP Patches for SC 4.7.1 and 4.6.2.2:
File                          md5sum        
SC-201502.2-php53-rh5-32.tgz  465c5da6a16e7caf7e7110916624b6c5
SC-201502.2-php53-rh5-64.tgz  f9dd149e395263d5592ff19d0c531ac1
SC-201502.2-php53-rh6-32.tgz  4240057a3865c50af610f717c8c85d26
SC-201502.2-php53-rh6-64.tgz  e4227104f2ff72514101bb62dfcfad3a
Tenable Appliance

Tenable has released a patch to update the Tenable Appliance to remediate the PHP issues listed above. The patch can be obtained from:

https://support.tenable.com/support-center/index.php?x=&mod_id=230

File                          md5sum        
SC-TNS-2015-02_3.2.0.tar.gz   c9f4daf66868520004870392cf5c959d
In addition, Tenable has released version 3.3.1 of the Appliance on March 2, 2015, that addresses these issues.

This page contains information regarding security vulnerabilities that may impact Tenable's products. This may include issues specific to our software, or due to the use of third-party libraries within our software. Tenable strongly encourages users to ensure that they upgrade or apply relevant patches in a timely manner.

Tenable takes product security very seriously. If you believe you have found a vulnerability in one of our products, we ask that you please work with us to quickly resolve it in order to protect customers. Tenable believes in responding quickly to such reports, maintaining communication with researchers, and providing a solution in short order.

For more details on submitting vulnerability information, please see our Vulnerability Reporting Guidelines page.

If you have questions or corrections about this advisory, please email [email protected]