Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

[R4] Tenable Products Affected by OpenSSL Protocol Downgrade Vulnerability



Tenable's SecurityCenter is affected by at least one vulnerability due to the use of a third-party library, specifically OpenSSL.

SecurityCenter's use of OpenSSL made it vulnerable to CVE-2014-3511, an issue with the ssl23_get_client_hello function in s23_srvr.c that could allow a remote, man-in-the-middle attacker to force the use of TLS 1.0 by triggering a ClientHello message fragmentation (aka a "protocol downgrade" attack). Once Tenable determined that one of the issues affected SecurityCenter, further testing was not performed to positively verify additional issues. Instead, Tenable opted to focus on integrating the latest version of OpenSSL which fixes all of them. As such, SecurityCenter might be affected by CVE-2014-3512 and CVE-2014-5139.

Tenable's Nessus and PVS are technically affected by CVE-2014-3508 (crypto/objects/obj_dat.c OBJ_obj2txt function information disclosure) due to them using the X509_name_oneline() function. However, both of them utilize it in command-line utilities that do not offer an attack vector that crosses privilege boundaries.

Note that additional vulnerabilities were fixed with the 1.0.1i release, but SecurityCenter is not affected by them. These include CVE-2014-3505, CVE-2014-3506, CVE-2014-3507, CVE-2014-3509, and CVE-2014-3510.

Please note that Tenable strongly recommends that SecurityCenter and the Tenable Appliance be installed on a subnet that is not Internet addressable.


Tenable has updated the products to address this issue. Please see the product-specific instructions below:


Tenable has released a patch for all supported versions of SecurityCenter that addresses this vulnerability. This patch applies OpenSSL 1.0.1i, which is not affected. This patch has been tested on SecurityCenter versions, 4.7.0, 4.7.1, 4.8.0, and 4.8.1. Upgrade information can be obtained from:


The patches can be obtained from:


File                                    md5sum
OpenSSL-patch-Aug2014-rh5-32.tgz        a734a584729cd34222979070443a4f9a 
OpenSSL-patch-Aug2014-rh5-64.tgz        75da02df97ddae68a33e274c46344aa0 
OpenSSL-patch-Aug2014-rh6-32.tgz        8b8cf69e94e2ac14bf3d41eab04437e5 
OpenSSL-patch-Aug2014-rh6-64.tgz        3c007c799636763c56ae2fedaa063882 

Tenable Appliance:

Tenable has released two patch scripts for all supported versions of the Appliance that address this vulnerability. The operating system patch updates the OpenSSL package to 0.9.8e-27.el5_10.4, which is not affected. The SecurityCenter patch updates its OpenSSL package to 1.0.1i, which is not affected. This patch has been tested on Tenable Appliance 2.4.1-0, 2.4.1-1, 2.6.1, 2.6.2, and 2.8.1.

The patches can be obtained from:


File                       md5sum
SC-TNS-2014-06.tar.gz      60f5e76ab989cd5754672ed77ce2e367
TA-TNS-2014-06.tar.gz      619e14f5e551b03c54670215e0f32912

Note that the previously released Apache support script (TNS-2014-04) must be applied first, to upgrade the Apache (and PHP if SC 4.8.1 is installed). If you upgrade to an appliance version prior to and including version 2.8.1, you will need to re-apply this patch.

Tenable has also released version 3.0.0 of the appliance which resolves this issue.

File                                        md5sum                                    SHA1 sum
TenableAppliance-3.0.0-64-update.tar        3830a586afa9f0fb4c70f1cfb119f839          2384da2a29ec860782c3cfd168334ed19b59bf4a
TenableAppliance-HyperV-3.0.0-64bit.zip     86911ed30f657b5ea5d19b529bae0610          3fb28fbafa611e2279e2d5f1b894de770c088453
TenableAppliance-VMware-3.0.0-64bit.ova     5fbb61a26a39b89e2024fe617a8e8d99          2f5bbf2d694d56f880bae328d58ca81c5c48a13a

This page contains information regarding security vulnerabilities that may impact Tenable's products. This may include issues specific to our software, or due to the use of third-party libraries within our software. Tenable strongly encourages users to ensure that they upgrade or apply relevant patches in a timely manner.

Tenable takes product security very seriously. If you believe you have found a vulnerability in one of our products, we ask that you please work with us to quickly resolve it in order to protect customers. Tenable believes in responding quickly to such reports, maintaining communication with researchers, and providing a solution in short order.

For more details on submitting vulnerability information, please see our Vulnerability Reporting Guidelines page.

If you have questions or corrections about this advisory, please email [email protected]

Try for Free Buy Now

Try Tenable.io Vulnerability Management


Enjoy full access to a modern, cloud-based vulnerability management platform that enables you to see and track all of your assets with unmatched accuracy. Sign up now and run your first scan within 60 seconds.

Buy Tenable.io Vulnerability Management

Enjoy full access to a modern, cloud-based vulnerability management platform that enables you to see and track all of your assets with unmatched accuracy. Purchase your annual subscription today.

65 assets

Try Nessus Professional Free


Nessus® is the most comprehensive vulnerability scanner on the market today. Nessus Professional will help automate the vulnerability scanning process, save time in your compliance cycles and allow you to engage your IT team.