Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Oracle JavaVM Database Takeover

A new vulnerability discovered in the Oracle Database JavaVM component can result in complete database compromise and shell access to the underlying server.

Background

Oracle released an out-of-band update to its flagship database product for an authenticated vulnerability in the JavaVM component. According to Oracle, the vulnerability "can result in complete compromise of the Oracle Database and shell access to the underlying server." The same issue was found and patched in the July 2018 critical patch update (CPU) but was not reported as a critical vulnerability for unspecified reasons.

Vulnerability details

According to Oracle, this vulnerability affects “...versions 11.2.0.4 and 12.2.0.1 on Windows. CVE-2018-3110 has a CVSS v3 base score of 9.9, and can result in complete compromise of the Oracle Database and shell access to the underlying server. CVE-2018-3110 also affects Oracle Database version 12.1.0.2 on Windows as well as Oracle Database on Linux and Unix, however patches for those versions and platforms were included in the July 2018 CPU.”

This vulnerability affects Windows Oracle databases via the “Oracle Net” protocol and requires a user with “Create Session” privileges for the JavaVM component. No credit was provided in the advisory and, as is often the case with many Oracle vulnerabilities, exploitation details are sparse.

Note: While CVE-2018-3004 from the July CPU appears to be related, as the same component is affected, Oracle has clarified that these CVEs are unrelated and the fix for CVE-2018-3110 was silently included in the July CPU for a subset of their product line in an effort to protect their customers.

Impact assessment

Because database authentication is required to exploit this vulnerability, the impact is lessened. However, the potential for complete database takeover means anyone with an Oracle database in their environment should take remediation steps immediately. In addition, enterprises running versions of Oracle DB which were patched for the July CPU are already protected.

Urgently required actions

If your business uses an Oracle database, we recommend updating immediately based on Oracle’s guidance

Tenable.io Vulnerability Management, Tenable.io Container Security, SecurityCenter and Nessus detect this vulnerability. Below is a list of plugins Tenable has released to determine if the Oracle databases in your environment are affected. Tenable will continue to monitor the situation and provide updated protection as required.

Plugin ID

Name

Description

111219

oracle_rdbms_cpu_jul_2018.nasl

July 2018 Oracle DB CPU

111680

oracle_rdbms_cve_2018_3110.nasl

August 2018 Oracle DB check for CVE-2018-3110

Learn more:

Learn more about Tenable.io, the first Cyber Exposure platform for holistic management of your modern attack surface. Get a free 60-day trial of Tenable.io Vulnerability Management.

Subscribe to the Tenable Blog

Subscribe
Try for Free Buy Now

Try Tenable.io Vulnerability Management

FREE FOR 60 DAYS

Enjoy full access to a modern, cloud-based vulnerability management platform that enables you to see and track all of your assets with unmatched accuracy. Sign up now and run your first scan within 60 seconds.

Buy Tenable.io Vulnerability Management

Enjoy full access to a modern, cloud-based vulnerability management platform that enables you to see and track all of your assets with unmatched accuracy. Purchase your annual subscription today.

65 assets
Try for Free Buy Now

Try Nessus Professional Free

FREE FOR 7 DAYS

Nessus® is the most comprehensive vulnerability scanner on the market today. Nessus Professional will help automate the vulnerability scanning process, save time in your compliance cycles and allow you to engage your IT team.

Buy Nessus Professional

Nessus® is the most comprehensive vulnerability scanner on the market today. Nessus Professional will help automate the vulnerability scanning process, save time in your compliance cycles and allow you to engage your IT team.

Purchase your 1-, 2-, or 3-year license today.