Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

[R6] Tenable Appliance 4.5.0 Fixes Multiple Vulnerabilities

Critical

Synopsis

The Tenable Appliance has recently been discovered to contain several vulnerabilities. One exists in the underlying operating system kernel, two in the Appliance web interface, and multiple issues in bundled applications. Since the Appliance ships with other Tenable products, please consult the associated advisories linked below for more details.

The following issues were found by Gregor Kopf:

  • Tenable Appliance Web UI Unauthorized Admin Password Manipulation (VulnDB 153134 / CVE-2017-8050)
  • Tenable Appliance Web UI /simpleupload.py tns_appliance_session_user Parameter Remote Command Execution (VulnDB 153135 / CVE-2017-8051)

  • Linux Kernel net/dccp/input.c dccp_rcv_state_process() Function DCCP_PKT_REQUEST Handling Use-after-free Remote Code Execution (VulnDB 152302 / CVE-2017-6074)
  • Tenable Nessus on Windows Unspecified Remote File Upload (TNS-2017-06, VulnDB 152378 / CVE-2017-6543)
  • Tenable SecurityCenter File Upload PHP Object Deserialization Remote File Deletion (TNS-2017-05, VulnDB 152286)
  • Tenable SecurityCenter Multiple Vulnerabilities (TNS-2017-04, See advisory for VDB IDs)

Tenable would like to thank Gregor Kopf of Recurity Labs GmbH, working in conjunction with a mutual customer, for discovering and reporting the two Web UI vulnerabilities. The associated CVSSv2 score for this advisory reflects the unauthenticated remote command execution issue.

Please note that Tenable strongly recommends that the Tenable Appliance be installed on a subnet that is not Internet addressable.

[1] The two vulnerabilities in the Web UI affects all appliances in the 3.x (3.4.0, 3.5.0, 3.5.1, 3.10.0, 3.10.1) and 4.x line (4.0.0, 4.1.0, 4.2.0, 4.3.0, 4.3.1, 4.4.0). Tenable has not tested the third-party code issues to determine how far back in the version line they go. If you are running an appliance prior to 4.5.0, no matter how old, it is strongly encouraged you upgrade to the latest version.

Solution

Tenable has released version 4.5.0 of the Appliance that resolves this issue. Users are strongly encouraged to use the online updating functionality or download the new version to upgrade.

On 2017-04-18, security researcher "agix" published an exploit for the remote command execution flaw (VulnDB 153135). As such, customers are more strongly encouraged to upgrade immediately.

This page contains information regarding security vulnerabilities that may impact Tenable's products. This may include issues specific to our software, or due to the use of third-party libraries within our software. Tenable strongly encourages users to ensure that they upgrade or apply relevant patches in a timely manner.

Tenable takes product security very seriously. If you believe you have found a vulnerability in one of our products, we ask that you please work with us to quickly resolve it in order to protect customers. Tenable believes in responding quickly to such reports, maintaining communication with researchers, and providing a solution in short order.

For more details on submitting vulnerability information, please see our Vulnerability Reporting Guidelines page.

If you have questions or corrections about this advisory, please email [email protected]