Facebook Google Plus Twitter LinkedIn YouTube RSS Menu Search Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

[R4] SecurityCenter 5.0.1 Fixes Third-party Library

High

Synopsis

SecurityCenter is potentially impacted by a vulnerability in PHP that was recently disclosed and fixed. Note that due to the time involved in doing a full analysis of the issue, Tenable has opted to patch the included version of PHP as a precaution, and to save time.

PHP escapeshellcmd() / escapeshellarg() ! Character Handling Unspecified Issue - PHP contains a flaw in the escapeshellcmd() and escapeshellarg() functions. The issue is triggered as the ! character is not properly handled. This may allow an attacker to e.g. substitute environment variables and have an unspecified impact.

Please note that Tenable strongly recommends that SecurityCenter be installed on a subnet that is not Internet addressable.

Solution

Tenable has released a patch for SecurityCenter 4.8.2 that addresses this vulnerability. This patch applies PHP 5.4.43, which is not affected. Upgrade information can be obtained from:

http://static.tenable.com/prod_docs/upgrade_security_center.html

The patch can be obtained from:

https://support.tenable.com/support-center/index.php?x=&mod_id=160

File	   		      md5sum
SC-201507.1-4.8.2-rh5-32.tgz  3ec16979decc453f302a1f2cf79cc630
SC-201507.1-4.8.2-rh5-64.tgz  11268f0c1420647429bb6860ba672255
SC-201507.1-4.8.2-rh6-32.tgz  3d669ff82aaa0f0c51936348b15c8818
SC-201507.1-4.8.2-rh6-64.tgz  bda1e9eff15135dfb2aaade09d39fbb6

Users of SecurityCenter 4.6.x and 4.7.x must upgrade to 4.8.2 or later and install the patch to resolve this issue, as the integrated version of PHP has been declared end-of-life and will not receive patches from the vendor. Users of SecurityCenter 5.0.0.1 must upgrade to 5.0.1 to resolve this issue.

Users of the Tenable Appliance 3.5.0 or 3.6.0 must upgrade to 3.7.0 to resolve this issue.

This page contains information regarding security vulnerabilities that may impact Tenable's products. This may include issues specific to our software, or due to the use of third-party libraries within our software. Tenable strongly encourages users to ensure that they upgrade or apply relevant patches in a timely manner.

Tenable takes product security very seriously. If you believe you have found a vulnerability in one of our products, we ask that you please work with us to quickly resolve it in order to protect customers. Tenable believes in responding quickly to such reports, maintaining communication with researchers, and providing a solution in short order.

For more details on submitting vulnerability information, please see our Vulnerability Reporting Guidelines page.

If you have questions or corrections about this advisory, please email [email protected]