GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)

High Nessus Plugin ID 95421


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201611-22 (PHP: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PHP. Please review the CVE identifiers referenced below for details.
Impact :

An attacker can possibly execute arbitrary code or create a Denial of Service condition.
Workaround :

There is no known workaround at this time.


All PHP users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev=lang/php-5.6.28'

See Also

Plugin Details

Severity: High

ID: 95421

File Name: gentoo_GLSA-201611-22.nasl

Version: $Revision: 3.1 $

Type: local

Published: 2016/12/01

Modified: 2016/12/01

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P


Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:php, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2016/11/30

Reference Information

CVE: CVE-2015-8865, CVE-2016-3074, CVE-2016-4071, CVE-2016-4072, CVE-2016-4073, CVE-2016-4537, CVE-2016-4538, CVE-2016-4539, CVE-2016-4540, CVE-2016-4541, CVE-2016-4542, CVE-2016-4543, CVE-2016-4544, CVE-2016-5385, CVE-2016-6289, CVE-2016-6290, CVE-2016-6291, CVE-2016-6292, CVE-2016-6294, CVE-2016-6295, CVE-2016-6296, CVE-2016-6297, CVE-2016-7124, CVE-2016-7125, CVE-2016-7126, CVE-2016-7127, CVE-2016-7128, CVE-2016-7129, CVE-2016-7130, CVE-2016-7131, CVE-2016-7132, CVE-2016-7133, CVE-2016-7134, CVE-2016-7411, CVE-2016-7412, CVE-2016-7413, CVE-2016-7414, CVE-2016-7416, CVE-2016-7417, CVE-2016-7418

GLSA: 201611-22