CVE-2016-7131

HIGH
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/wddx/wddx.c in PHP before 5.6.25 and 7.x before 7.0.10 allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) or possibly have unspecified other impact via a malformed wddxPacket XML document that is mishandled in a wddx_deserialize call, as demonstrated by a tag that lacks a < (less than) character.

References

http://openwall.com/lists/oss-security/2016/09/02/9

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/92768

http://www.securitytracker.com/id/1036680

https://bugs.php.net/bug.php?id=72790

https://github.com/php/php-src/commit/0c8a2a2cd1056b7dc403eacb5d2c0eec6ce47c6f

https://github.com/php/php-src/commit/a14fdb9746262549bbbb96abb87338bacd147e1b?w=1

https://security.gentoo.org/glsa/201611-22

https://www.tenable.com/security/tns-2016-19

Details

Source: MITRE

Published: 2016-09-12

Updated: 2020-11-16

Type: CWE-476

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
98834PHP 7.0.x < 7.0.10 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98815PHP 5.6.x < 5.6.25 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119981SUSE SLES12 Security Update : php7 (SUSE-SU-2016:2460-1)NessusSuSE Local Security Checks
critical
119979SUSE SLES12 Security Update : php5 (SUSE-SU-2016:2408-1)NessusSuSE Local Security Checks
critical
101047Tenable SecurityCenter PHP < 5.6.25 Multiple Vulnerabilities (TNS-2016-09)NessusMisc.
critical
99915EulerOS 2.0 SP2 : php (EulerOS-SA-2017-1068)NessusHuawei Local Security Checks
high
99914EulerOS 2.0 SP1 : php (EulerOS-SA-2017-1067)NessusHuawei Local Security Checks
high
96832Tenable SecurityCenter < 5.4.1 Multiple Vulnerabilities (TNS-2016-19)NessusMisc.
critical
96010Debian DLA-749-1 : php5 security update (httpoxy)NessusDebian Local Security Checks
critical
95421GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)NessusGentoo Local Security Checks
critical
93914Debian DSA-3689-1 : php5 - security updateNessusDebian Local Security Checks
critical
93894SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2459-1)NessusSuSE Local Security Checks
critical
93864Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3095-1)NessusUbuntu Local Security Checks
critical
93856openSUSE Security Update : php5 (openSUSE-2016-1156)NessusSuSE Local Security Checks
critical
9551PHP 5.6.x < 5.6.25 / 7.0.x < 7.0.10 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
93597openSUSE Security Update : php5 (openSUSE-2016-1095)NessusSuSE Local Security Checks
critical
93589SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2328-1)NessusSuSE Local Security Checks
critical
93384Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-252-01)NessusSlackware Local Security Checks
critical
93078PHP 7.0.x < 7.0.10 Multiple VulnerabilitiesNessusCGI abuses
critical
93077PHP 5.6.x < 5.6.25 Multiple VulnerabilitiesNessusCGI abuses
critical