CVE-2016-4538

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The bcpowmod function in ext/bcmath/bcmath.c in PHP before 5.5.35, 5.6.x before 5.6.21, and 7.x before 7.0.6 modifies certain data structures without considering whether they are copies of the _zero_, _one_, or _two_ global variable, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted call.

References

http://lists.fedoraproject.org/pipermail/package-announce/2016-May/183736.html

http://lists.opensuse.org/opensuse-updates/2016-05/msg00086.html

http://lists.opensuse.org/opensuse-updates/2016-06/msg00027.html

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.debian.org/security/2016/dsa-3602

http://www.openwall.com/lists/oss-security/2016/05/05/21

http://www.securityfocus.com/bid/90173

https://bugs.php.net/bug.php?id=72093

https://git.php.net/?p=php-src.git;a=commit;h=d650063a0457aec56364e4005a636dc6c401f9cd

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05320149

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05390722

https://security.gentoo.org/glsa/201611-22

Details

Source: MITRE

Published: 2016-05-22

Updated: 2018-10-30

Type: CWE-20

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
129236EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2043)NessusHuawei Local Security Checks
critical
128931EulerOS Virtualization for ARM 64 3.0.2.0 : php (EulerOS-SA-2019-1928)NessusHuawei Local Security Checks
critical
128917EulerOS 2.0 SP2 : php (EulerOS-SA-2019-1865)NessusHuawei Local Security Checks
critical
128087EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1795)NessusHuawei Local Security Checks
critical
98852PHP 7.0.x < 7.0.6 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98811PHP 5.6.x < 5.6.21 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119978SUSE SLES12 Security Update : php5 (SUSE-SU-2016:1504-1)NessusSuSE Local Security Checks
high
95421GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)NessusGentoo Local Security Checks
critical
94654HP System Management Homepage < 7.6 Multiple Vulnerabilities (HPSBMU03653) (httpoxy)NessusWeb Servers
high
93568Debian DLA-628-1 : php5 security updateNessusDebian Local Security Checks
critical
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
9393PHP 5.5.x < 5.5.37 / 5.6.x < 5.6.23 / 7.0.x < 7.0.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
91814Tenable SecurityCenter < 5.3.2 Multiple Vulnerabilities (TNS-2016-09)NessusMisc.
critical
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
91615Debian DSA-3602-1 : php5 - security updateNessusDebian Local Security Checks
critical
91531openSUSE Security Update : php5 (openSUSE-2016-696)NessusSuSE Local Security Checks
critical
91320Ubuntu 12.04 LTS / 14.04 LTS / 15.10 / 16.04 LTS : php5, php7.0 vulnerabilities (USN-2984-1)NessusUbuntu Local Security Checks
critical
90978Fedora 24 : php-5.6.21-1.fc24 (2016-f4e73663f4)NessusFedora Local Security Checks
critical
90922PHP 7.0.x < 7.0.6 Multiple VulnerabilitiesNessusCGI abuses
critical
90921PHP 5.6.x < 5.6.21 Multiple VulnerabilitiesNessusCGI abuses
critical
90920PHP 5.5.x < 5.5.35 Multiple VulnerabilitiesNessusCGI abuses
critical
89093openSUSE Security Update : libqt5-qtbase (openSUSE-2016-613)NessusSuSE Local Security Checks
critical