CVE-2016-7125

MEDIUM

Description

ext/session/session.c in PHP before 5.6.25 and 7.x before 7.0.10 skips invalid session names in a way that triggers incorrect parsing, which allows remote attackers to inject arbitrary-type session data by leveraging control of a session name, as demonstrated by object injection.

References

http://openwall.com/lists/oss-security/2016/09/02/9

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/92552

http://www.securitytracker.com/id/1036680

https://bugs.php.net/bug.php?id=72681

https://github.com/php/php-src/commit/8763c6090d627d8bb0ee1d030c30e58f406be9ce?w=1

https://security.gentoo.org/glsa/201611-22

https://www.tenable.com/security/tns-2016-19

Details

Source: MITRE

Published: 2016-09-12

Updated: 2018-01-05

Type: CWE-74

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
129178EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1984)NessusHuawei Local Security Checks
high
98834PHP 7.0.x < 7.0.10 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98815PHP 5.6.x < 5.6.25 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
119981SUSE SLES12 Security Update : php7 (SUSE-SU-2016:2460-1)NessusSuSE Local Security Checks
high
119979SUSE SLES12 Security Update : php5 (SUSE-SU-2016:2408-1)NessusSuSE Local Security Checks
high
101047Tenable SecurityCenter PHP < 5.6.25 Multiple Vulnerabilities (TNS-2016-09)NessusMisc.
high
97478F5 Networks BIG-IP : PHP vulnerability (K35232053)NessusF5 Networks Local Security Checks
medium
96832Tenable SecurityCenter < 5.4.1 Multiple Vulnerabilities (TNS-2016-19)NessusMisc.
high
95421GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)NessusGentoo Local Security Checks
high
93914Debian DSA-3689-1 : php5 - security updateNessusDebian Local Security Checks
high
93894SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2459-1)NessusSuSE Local Security Checks
high
93864Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3095-1)NessusUbuntu Local Security Checks
high
93856openSUSE Security Update : php5 (openSUSE-2016-1156)NessusSuSE Local Security Checks
high
9551PHP 5.6.x < 5.6.25 / 7.0.x < 7.0.10 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
93597openSUSE Security Update : php5 (openSUSE-2016-1095)NessusSuSE Local Security Checks
high
93589SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2328-1)NessusSuSE Local Security Checks
high
93384Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-252-01)NessusSlackware Local Security Checks
high
93078PHP 7.0.x < 7.0.10 Multiple VulnerabilitiesNessusCGI abuses
high
93077PHP 5.6.x < 5.6.25 Multiple VulnerabilitiesNessusCGI abuses
high