CVE-2016-7416

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/intl/msgformat/msgformat_format.c in PHP before 5.6.26 and 7.x before 7.0.11 does not properly restrict the locale length provided to the Locale class in the ICU library, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a MessageFormatter::formatMessage call with a long first argument.

References

http://www.openwall.com/lists/oss-security/2016/09/15/10

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/93008

http://www.securitytracker.com/id/1036836

https://access.redhat.com/errata/RHSA-2018:1296

https://bugs.php.net/bug.php?id=73007

https://github.com/php/php-src/commit/6d55ba265637d6adf0ba7e9c9ef11187d1ec2f5b?w=1

https://security.gentoo.org/glsa/201611-22

https://www.tenable.com/security/tns-2016-19

Details

Source: MITRE

Published: 2016-09-17

Updated: 2018-05-04

Type: CWE-119

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Impact Score: 3.6

Exploitability Score: 3.9

Severity: HIGH

Tenable Plugins

View all (27 total)

IDNameProductFamilySeverity
98835PHP 7.0.x < 7.0.11 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98816PHP 5.6.x < 5.6.26 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119983SUSE SLES12 Security Update : php5 (SUSE-SU-2016:2477-1)NessusSuSE Local Security Checks
critical
119981SUSE SLES12 Security Update : php7 (SUSE-SU-2016:2460-1)NessusSuSE Local Security Checks
critical
101048Tenable SecurityCenter PHP < 5.6.26 Multiple VulnerabilitiesNessusMisc.
critical
99915EulerOS 2.0 SP2 : php (EulerOS-SA-2017-1068)NessusHuawei Local Security Checks
high
99914EulerOS 2.0 SP1 : php (EulerOS-SA-2017-1067)NessusHuawei Local Security Checks
high
96832Tenable SecurityCenter < 5.4.1 Multiple Vulnerabilities (TNS-2016-19)NessusMisc.
critical
96010Debian DLA-749-1 : php5 security update (httpoxy)NessusDebian Local Security Checks
critical
95917macOS 10.12.x < 10.12.2 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
high
95421GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)NessusGentoo Local Security Checks
critical
94089openSUSE Security Update : php5 (openSUSE-2016-1193)NessusSuSE Local Security Checks
critical
94084FreeBSD : PHP -- multiple vulnerabilities (f471032a-8700-11e6-8d93-00248c0c745d)NessusFreeBSD Local Security Checks
critical
94083FreeBSD : PHP -- multiple vulnerabilities (8d5180a6-86fe-11e6-8d93-00248c0c745d)NessusFreeBSD Local Security Checks
critical
94020Amazon Linux AMI : php70 (ALAS-2016-754)NessusAmazon Linux Local Security Checks
critical
94019Amazon Linux AMI : php56 (ALAS-2016-753)NessusAmazon Linux Local Security Checks
critical
93914Debian DSA-3689-1 : php5 - security updateNessusDebian Local Security Checks
critical
93895SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2461-1)NessusSuSE Local Security Checks
critical
93894SUSE SLES11 Security Update : php53 (SUSE-SU-2016:2459-1)NessusSuSE Local Security Checks
critical
93864Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3095-1)NessusUbuntu Local Security Checks
critical
93853openSUSE Security Update : php5 (openSUSE-2016-1150)NessusSuSE Local Security Checks
critical
93754Fedora 23 : php (2016-db71b72137)NessusFedora Local Security Checks
critical
93726Fedora 24 : php (2016-62fc05fd68)NessusFedora Local Security Checks
critical
9580PHP 5.6.x < 5.6.26 / 7.0.x < 7.0.11 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
93687Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-267-01)NessusSlackware Local Security Checks
critical
93657PHP 7.0.x < 7.0.11 Multiple VulnerabilitiesNessusCGI abuses
critical
93656PHP 5.6.x < 5.6.26 Multiple VulnerabilitiesNessusCGI abuses
critical