CVE-2015-8865

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The file_check_mem function in funcs.c in file before 5.23, as used in the Fileinfo component in PHP before 5.5.34, 5.6.x before 5.6.20, and 7.x before 7.0.5, mishandles continuation-level jumps, which allows context-dependent attackers to cause a denial of service (buffer overflow and application crash) or possibly execute arbitrary code via a crafted magic file.

References

http://bugs.gw.com/view.php?id=522

http://git.php.net/?p=php-src.git;a=commit;h=fe13566c93f118a15a96320a546c7878fd0cfc5e

http://lists.apple.com/archives/security-announce/2016/May/msg00004.html

http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00057.html

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.debian.org/security/2016/dsa-3560

http://www.openwall.com/lists/oss-security/2016/04/24/1

http://www.php.net/ChangeLog-5.php

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/85802

http://www.ubuntu.com/usn/USN-2952-1

http://www.ubuntu.com/usn/USN-2952-2

https://bugs.php.net/bug.php?id=71527

https://github.com/file/file/commit/6713ca45e7757297381f4b4cdb9cf5e624a9ad36

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

https://security.gentoo.org/glsa/201611-22

https://security.gentoo.org/glsa/201701-42

https://support.apple.com/HT206567

https://usn.ubuntu.com/3686-1/

https://usn.ubuntu.com/3686-2/

Details

Source: MITRE

Published: 2016-05-20

Updated: 2018-06-30

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 7.3

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 1.3

Severity: HIGH

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
129236EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2043)NessusHuawei Local Security Checks
critical
128931EulerOS Virtualization for ARM 64 3.0.2.0 : php (EulerOS-SA-2019-1928)NessusHuawei Local Security Checks
critical
128917EulerOS 2.0 SP2 : php (EulerOS-SA-2019-1865)NessusHuawei Local Security Checks
critical
128087EulerOS 2.0 SP5 : php (EulerOS-SA-2019-1795)NessusHuawei Local Security Checks
critical
98851PHP 7.0.x < 7.0.5 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
98810PHP 5.6.x < 5.6.20 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
110552Ubuntu 14.04 LTS / 16.04 LTS / 17.10 / 18.04 LTS : file vulnerabilities (USN-3686-1)NessusUbuntu Local Security Checks
high
97447F5 Networks BIG-IP : PHP vulnerability (K54924436)NessusF5 Networks Local Security Checks
high
96576GLSA-201701-42 : file: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
95421GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)NessusGentoo Local Security Checks
critical
9392Mac OS X 10.11.x < 10.11.5 Multiple VulnerabilitiesNessus Network MonitorOperating System Detection
high
91397Debian DLA-499-1 : php5 security updateNessusDebian Local Security Checks
critical
91320Ubuntu 12.04 LTS / 14.04 LTS / 15.10 / 16.04 LTS : php5, php7.0 vulnerabilities (USN-2984-1)NessusUbuntu Local Security Checks
critical
90944Debian DLA-460-1 : file security updateNessusDebian Local Security Checks
high
90867Amazon Linux AMI : php56 / php55 (ALAS-2016-698)NessusAmazon Linux Local Security Checks
critical
90768Debian DSA-3560-1 : php5 - security updateNessusDebian Local Security Checks
critical
90362PHP 7.0.x < 7.0.5 Multiple VulnerabilitiesNessusCGI abuses
critical
90361PHP 5.6.x < 5.6.20 Multiple VulnerabilitiesNessusCGI abuses
critical
90360PHP 5.5.x < 5.5.34 Multiple VulnerabilitiesNessusCGI abuses
critical