CVE-2016-7134

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

ext/curl/interface.c in PHP 7.x before 7.0.10 does not work around a libcurl integer overflow, which allows remote attackers to cause a denial of service (allocation error and heap-based buffer overflow) or possibly have unspecified other impact via a long string that is mishandled in a curl_escape call.

References

http://openwall.com/lists/oss-security/2016/09/02/9

http://www.php.net/ChangeLog-7.php

http://www.securityfocus.com/bid/92766

http://www.securitytracker.com/id/1036680

https://bugs.php.net/bug.php?id=72674

https://github.com/php/php-src/commit/72dbb7f416160f490c4e9987040989a10ad431c7?w=1

https://security.gentoo.org/glsa/201611-22

Details

Source: MITRE

Published: 2016-09-12

Updated: 2017-08-16

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (10 total)

IDNameProductFamilySeverity
98834PHP 7.0.x < 7.0.10 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
critical
119981SUSE SLES12 Security Update : php7 (SUSE-SU-2016:2460-1)NessusSuSE Local Security Checks
critical
119979SUSE SLES12 Security Update : php5 (SUSE-SU-2016:2408-1)NessusSuSE Local Security Checks
critical
95421GLSA-201611-22 : PHP: Multiple vulnerabilities (httpoxy)NessusGentoo Local Security Checks
critical
93864Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3095-1)NessusUbuntu Local Security Checks
critical
93856openSUSE Security Update : php5 (openSUSE-2016-1156)NessusSuSE Local Security Checks
critical
9551PHP 5.6.x < 5.6.25 / 7.0.x < 7.0.10 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
93597openSUSE Security Update : php5 (openSUSE-2016-1095)NessusSuSE Local Security Checks
critical
93384Slackware 14.0 / 14.1 / 14.2 / current : php (SSA:2016-252-01)NessusSlackware Local Security Checks
critical
93078PHP 7.0.x < 7.0.10 Multiple VulnerabilitiesNessusCGI abuses
critical