Slackware Linux 15.0 / current mozilla-firefox Multiple Vulnerabilities (SSA:2022-179-02)

critical Nessus Plugin ID 162577

Synopsis

The remote Slackware Linux host is missing a security update to mozilla-firefox.

Description

The version of mozilla-firefox installed on the remote host is prior to 102.0 / 91.11.0esr. It is, therefore, affected by multiple vulnerabilities as referenced in the SSA:2022-179-02 advisory.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade the affected mozilla-firefox package.

Plugin Details

Severity: Critical

ID: 162577

File Name: Slackware_SSA_2022-179-02.nasl

Version: 1.2

Type: local

Published: 6/28/2022

Updated: 6/28/2022

Risk Information

VPR

Risk Factor: High

Score: 8.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-34484

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:slackware:slackware_linux:*:*:*:*:*:*:*:*, p-cpe:2.3:a:slackware:slackware_linux:mozilla-firefox:*:*:*:*:*:*:*, cpe:2.3:o:slackware:slackware_linux:15.0:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Slackware/release, Host/Slackware/packages

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 6/2/2022

Reference Information

CVE: CVE-2022-31744, CVE-2022-34479, CVE-2022-34470, CVE-2022-34468, CVE-2022-34481, CVE-2022-34472, CVE-2022-34478, CVE-2022-2200, CVE-2022-34484