CVE-2022-34481

high

Description

In the <code>nsTArray_Impl::ReplaceElementsAt()</code> function, an integer overflow could have occurred when the number of elements to replace was too large for the container. This vulnerability affects Firefox < 102, Firefox ESR < 91.11, Thunderbird < 102, and Thunderbird < 91.11.

References

https://www.mozilla.org/security/advisories/mfsa2022-24/

https://bugzilla.mozilla.org/show_bug.cgi?id=1497246

https://www.mozilla.org/security/advisories/mfsa2022-26/

https://www.mozilla.org/security/advisories/mfsa2022-25/

Details

Source: MITRE

Published: 2022-12-22

Updated: 2022-12-30

Type: CWE-190