openSUSE Security Update : chromium (openSUSE-2020-189)

high Nessus Plugin ID 133593

Language:

Synopsis

The remote openSUSE host is missing a security update.

Description

This update for chromium fixes the following issues :

Chromium was updated to version 80.0.3987.87 (boo#1162833).

Security issues fixed :

- CVE-2020-6381: Integer overflow in JavaScript (boo#1162833).

- CVE-2020-6382: Type Confusion in JavaScript (boo#1162833).

- CVE-2019-18197: Multiple vulnerabilities in XML (boo#1162833).

- CVE-2019-19926: Inappropriate implementation in SQLite (boo#1162833).

- CVE-2020-6385: Insufficient policy enforcement in storage (boo#1162833).

- CVE-2019-19880, CVE-2019-19925: Multiple vulnerabilities in SQLite (boo#1162833).

- CVE-2020-6387: Out of bounds write in WebRTC (boo#1162833).

- CVE-2020-6388: Out of bounds memory access in WebAudio (boo#1162833).

- CVE-2020-6389: Out of bounds write in WebRTC (boo#1162833).

- CVE-2020-6390: Out of bounds memory access in streams (boo#1162833).

- CVE-2020-6391: Insufficient validation of untrusted input in Blink (boo#1162833).

- CVE-2020-6392: Insufficient policy enforcement in extensions (boo#1162833).

- CVE-2020-6393: Insufficient policy enforcement in Blink (boo#1162833).

- CVE-2020-6394: Insufficient policy enforcement in Blink (boo#1162833).

- CVE-2020-6395: Out of bounds read in JavaScript (boo#1162833).

- CVE-2020-6396: Inappropriate implementation in Skia (boo#1162833).

- CVE-2020-6397: Incorrect security UI in sharing (boo#1162833).

- CVE-2020-6398: Uninitialized use in PDFium (boo#1162833).

- CVE-2020-6399: Insufficient policy enforcement in AppCache (boo#1162833).

- CVE-2020-6400: Inappropriate implementation in CORS (boo#1162833).

- CVE-2020-6401: Insufficient validation of untrusted input in Omnibox (boo#1162833).

- CVE-2020-6402: Insufficient policy enforcement in downloads (boo#1162833).

- CVE-2020-6403: Incorrect security UI in Omnibox (boo#1162833).

- CVE-2020-6404: Inappropriate implementation in Blink (boo#1162833).

- CVE-2020-6405: Out of bounds read in SQLite (boo#1162833).

- CVE-2020-6406: Use after free in audio (boo#1162833).

- CVE-2019-19923: Out of bounds memory access in SQLite (boo#1162833).

- CVE-2020-6408: Insufficient policy enforcement in CORS (boo#1162833).

- CVE-2020-6409: Inappropriate implementation in Omnibox (boo#1162833).

- CVE-2020-6410: Insufficient policy enforcement in navigation (boo#1162833).

- CVE-2020-6411: Insufficient validation of untrusted input in Omnibox (boo#1162833).

- CVE-2020-6412: Insufficient validation of untrusted input in Omnibox (boo#1162833).

- CVE-2020-6413: Inappropriate implementation in Blink (boo#1162833).

- CVE-2020-6414: Insufficient policy enforcement in Safe Browsing (boo#1162833).

- CVE-2020-6415: Inappropriate implementation in JavaScript (boo#1162833).

- CVE-2020-6416: Insufficient data validation in streams (boo#1162833).

- CVE-2020-6417: Inappropriate implementation in installer (boo#1162833).

Solution

Update the affected chromium packages.

See Also

https://bugzilla.opensuse.org/show_bug.cgi?id=1162833

Plugin Details

Severity: High

ID: 133593

File Name: openSUSE-2020-189.nasl

Version: 1.7

Type: local

Agent: unix

Published: 2/10/2020

Updated: 4/4/2022

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2020-6416

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.8

Temporal Score: 7.9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:chromedriver, p-cpe:/a:novell:opensuse:chromedriver-debuginfo, p-cpe:/a:novell:opensuse:chromium, p-cpe:/a:novell:opensuse:chromium-debuginfo, p-cpe:/a:novell:opensuse:chromium-debugsource, cpe:/o:novell:opensuse:15.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/8/2020

Vulnerability Publication Date: 10/18/2019

Reference Information

CVE: CVE-2019-18197, CVE-2019-19880, CVE-2019-19923, CVE-2019-19925, CVE-2019-19926, CVE-2020-6381, CVE-2020-6382, CVE-2020-6385, CVE-2020-6387, CVE-2020-6388, CVE-2020-6389, CVE-2020-6390, CVE-2020-6391, CVE-2020-6392, CVE-2020-6393, CVE-2020-6394, CVE-2020-6395, CVE-2020-6396, CVE-2020-6397, CVE-2020-6398, CVE-2020-6399, CVE-2020-6400, CVE-2020-6401, CVE-2020-6402, CVE-2020-6403, CVE-2020-6404, CVE-2020-6405, CVE-2020-6406, CVE-2020-6408, CVE-2020-6409, CVE-2020-6410, CVE-2020-6411, CVE-2020-6412, CVE-2020-6413, CVE-2020-6414, CVE-2020-6415, CVE-2020-6416, CVE-2020-6417