PHP 5.3.x < 5.3.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5242


The remote web server uses a version of PHP that is vulnerable to multiple attack vectors.


According to its banner, the version of PHP 5.3.x installed on the remote host is earlier than 5.3.1. Such versions are potentially affected by multiple issues :

- Sanity checks are missing in exif processing.

- It is possible to bypass the 'safe_mode' configuration setting using 'tempnam()'.

- It is possible to bypass the 'open_basedir' configuration setting using 'posix_mkfifo()'.

- The 'safe_mode_include_dir' configuration setting may be ignored.

- Calling 'popen()' with an invalid mode can cause a crash.

- A safe_mode restriction-bypass vulnerability because environment variables specified for 'proc_open' are passed without checking them.


Upgrade to PHP version 5.3.1 or later.

See Also

Plugin Details

Severity: High

ID: 5242

Family: Web Servers

Published: 2009/11/25

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 42862

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2009/11/19

Vulnerability Publication Date: 2009/11/19

Reference Information

CVE: CVE-2009-3557, CVE-2009-3559, CVE-2009-4017, CVE-2009-4018, CVE-2010-1128

BID: 36554, 36555, 37079, 37138