CVE-2010-1128

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The Linear Congruential Generator (LCG) in PHP before 5.2.13 does not provide the expected entropy, which makes it easier for context-dependent attackers to guess values that were intended to be unpredictable, as demonstrated by session cookies generated by using the uniqid function.

References

http://secunia.com/advisories/38708

http://secunia.com/advisories/42410

http://www.php.net/ChangeLog-5.php

http://www.php.net/releases/5_2_13.php

http://www.redhat.com/support/errata/RHSA-2010-0919.html

http://www.securityfocus.com/bid/38430

http://www.vupen.com/english/advisories/2010/0479

http://www.vupen.com/english/advisories/2010/3081

Details

Source: MITRE

Published: 2010-03-26

Updated: 2010-12-10

Type: CWE-310

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
68150Oracle Linux 4 / 5 : php (ELSA-2010-0919)NessusOracle Linux Local Security Checks
medium
60908Scientific Linux Security Update : php on SL4.x, SL5.x i386/x86_64NessusScientific Linux Local Security Checks
medium
56459GLSA-201110-06 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
50862CentOS 4 / 5 : php (CESA-2010:0919)NessusCentOS Local Security Checks
medium
50841RHEL 4 / 5 : php (RHSA-2010:0919)NessusRed Hat Local Security Checks
medium
49306Ubuntu 6.06 LTS / 8.04 LTS / 9.04 / 9.10 / 10.04 LTS : php5 vulnerabilities (USN-989-1)NessusUbuntu Local Security Checks
high
45029Mandriva Linux Security Advisory : php (MDVSA-2010:058)NessusMandriva Local Security Checks
high
801102PHP < 5.3.2 / 5.2.13 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
medium
5346PHP < 5.2.13 / 5.3.x < 5.3.2 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
44921PHP < 5.3.2 / 5.2.13 Multiple VulnerabilitiesNessusCGI abuses
medium
5242PHP 5.3.x < 5.3.1 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
42862PHP 5.3 < 5.3.1 Multiple VulnerabilitiesNessusCGI abuses
medium