PHP 5.3 < 5.3.1 Multiple Vulnerabilities

Medium Nessus Plugin ID 42862

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 7.4


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP 5.3 installed on the remote host is older than 5.3.1. Such versions may be affected by several security issues :

- Sanity checks are missing in exif processing.

- It is possible to bypass the 'safe_mode' configuration setting using 'tempnam()'.

- It is possible to bypass the 'open_basedir' configuration setting using 'posix_mkfifo()'.

- The 'safe_mode_include_dir' configuration setting may be ignored. (Bug #50063)

- Calling 'popen()' with an invalid mode can cause a crash under Windows. (Bug #44683)

- Provided file uploading is enabled (it is by default), an attacker can upload files using a POST request with 'multipart/form-data' content even if the target script doesn't actually support file uploads per se. By supplying a large number (15,000+) of files, an attacker could cause the web server to stop responding while it processes the file list.

- 'proc_open()' can bypass 'safe_mode_protected_env_vars'.
(Bug #49026)

- An unspecified vulnerability affects the LCG entropy.


Upgrade to PHP version 5.3.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 42862

File Name: php_5_3_1.nasl

Version: 1.21

Type: remote

Family: CGI abuses

Published: 2009/11/20

Updated: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: Medium

VPR Score: 7.4

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2009/11/19

Reference Information

CVE: CVE-2009-3557, CVE-2009-3559, CVE-2009-4017, CVE-2009-4018, CVE-2010-1128

BID: 36554, 36555, 37079, 37138

Secunia: 37412

CWE: 264