CVE-2009-3559

HIGH

Description

** DISPUTED ** main/streams/plain_wrapper.c in PHP 5.3.x before 5.3.1 does not recognize the safe_mode_include_dir directive, which allows context-dependent attackers to have an unknown impact by triggering the failure of PHP scripts that perform include or require operations, as demonstrated by a script that attempts to perform a require_once on a file in a standard library directory. NOTE: a reliable third party reports that this is not a vulnerability, because it results in a more restrictive security policy.

References

http://bugs.php.net/bug.php?id=50063

http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html

http://news.php.net/php.announce/79

http://support.apple.com/kb/HT4077

http://www.mandriva.com/security/advisories?name=MDVSA-2009:302

http://www.openwall.com/lists/oss-security/2009/11/20/2

http://www.openwall.com/lists/oss-security/2009/11/20/3

http://www.openwall.com/lists/oss-security/2009/11/20/5

http://www.php.net/ChangeLog-5.php

http://www.php.net/releases/5_3_1.php

Details

Source: MITRE

Published: 2009-11-23

Updated: 2010-04-01

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH