PHP 4.x < 4.4.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4620

Synopsis

The remote web server uses a version of PHP that is affected by multiple issues.

Description

According to its banner, the version of PHP 4.x installed on the remote host is older than 4.4.9. Such versions address several security issues, including :

- An update of PCRE to version 7.7.
- An overflow in memnstr().
- A crash in imageloadfont when an invalid font is given.
- An open_basedir handling issue in the curl extension.
- 'mbstring.func_overload' set in '.htaccess' becomes global. Note that the release announcement states this will be the last release for the PHP 4.4 series.

Solution

Upgrade to version 4.4.9 or higher.

See Also

http://www.openwall.com/lists/oss-security/2008/08/08/2

http://www.php.net/ChangeLog-4.php#4.4.9

http://bugs.php.net/bug.php?id=27421

http://www.php.net/releases/4_4_9.php

Plugin Details

Severity: High

ID: 4620

File Name: 4620.prm

Family: Web Servers

Published: 2008/08/11

Modified: 2016/11/23

Dependencies: 8728

Nessus ID: 32123, 33849

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2008/08/07

Vulnerability Publication Date: 2008/08/01

Reference Information

CVE: CVE-2007-4850, CVE-2008-0674, CVE-2008-2050, CVE-2008-2051, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660

BID: 27413, 30649, 31612, 33542