PHP < 5.2.6 Multiple Vulnerabilities

High Nessus Plugin ID 32123

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 6.7


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP installed on the remote host is older than 5.2.6. Such versions may be affected by the following issues :

- A stack-based buffer overflow in FastCGI SAPI.

- An integer overflow in printf().

- An security issue arising from improper calculation of the length of PATH_TRANSLATED in cgi_main.c.

- A safe_mode bypass in cURL.

- Incomplete handling of multibyte chars inside escapeshellcmd().

- Issues in the bundled PCRE fixed by version 7.6.


Upgrade to PHP version 5.2.6 or later.

See Also

Plugin Details

Severity: High

ID: 32123

File Name: php_5_2_6.nasl

Version: 1.29

Type: remote

Family: CGI abuses

Published: 2008/05/02

Updated: 2021/01/19

Dependencies: 48243

Risk Information

Risk Factor: High

VPR Score: 6.7

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Reference Information

CVE: CVE-2007-4850, CVE-2007-6039, CVE-2008-0599, CVE-2008-1384, CVE-2008-2050, CVE-2008-2051

BID: 27413, 28392, 29009

Secunia: 30048

CWE: 20, 119, 264