CVE-2008-2051

HIGH

Description

The escapeshellcmd API function in PHP before 5.2.6 has unknown impact and context-dependent attack vectors related to "incomplete multibyte chars."

References

http://lists.apple.com/archives/security-announce//2008/Jul/msg00003.html

http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00001.html

http://secunia.com/advisories/30048

http://secunia.com/advisories/30083

http://secunia.com/advisories/30158

http://secunia.com/advisories/30288

http://secunia.com/advisories/30345

http://secunia.com/advisories/30411

http://secunia.com/advisories/30757

http://secunia.com/advisories/30828

http://secunia.com/advisories/30967

http://secunia.com/advisories/31119

http://secunia.com/advisories/31124

http://secunia.com/advisories/31200

http://secunia.com/advisories/31326

http://secunia.com/advisories/32746

http://security.gentoo.org/glsa/glsa-200811-05.xml

http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0176

http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0178

http://www.debian.org/security/2008/dsa-1572

http://www.debian.org/security/2008/dsa-1578

http://www.mandriva.com/security/advisories?name=MDVSA-2008:125

http://www.mandriva.com/security/advisories?name=MDVSA-2008:126

http://www.mandriva.com/security/advisories?name=MDVSA-2008:127

http://www.mandriva.com/security/advisories?name=MDVSA-2008:128

http://www.openwall.com/lists/oss-security/2008/05/02/2

http://www.php.net/ChangeLog-5.php

http://www.redhat.com/support/errata/RHSA-2008-0505.html

http://www.redhat.com/support/errata/RHSA-2008-0544.html

http://www.redhat.com/support/errata/RHSA-2008-0545.html

http://www.redhat.com/support/errata/RHSA-2008-0546.html

http://www.redhat.com/support/errata/RHSA-2008-0582.html

http://www.securityfocus.com/archive/1/492535/100/0/threaded

http://www.securityfocus.com/archive/1/492671/100/0/threaded

http://www.securityfocus.com/bid/29009

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2008&m=slackware-security.488951

http://www.ubuntu.com/usn/usn-628-1

http://www.vupen.com/english/advisories/2008/1412

http://www.vupen.com/english/advisories/2008/2268

https://issues.rpath.com/browse/RPL-2503

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10256

https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00773.html

https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00779.html

Details

Source: MITRE

Published: 2008-05-05

Updated: 2018-10-11

Risk Information

CVSS v2.0

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

Tenable Plugins

View all (27 total)

IDNameProductFamilySeverity
67712Oracle Linux 4 : php (ELSA-2008-0545)NessusOracle Linux Local Security Checks
critical
67711Oracle Linux 3 / 5 : php (ELSA-2008-0544)NessusOracle Linux Local Security Checks
critical
60445Scientific Linux Security Update : php on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
60444Scientific Linux Security Update : php on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
critical
43693CentOS 4 : php (CESA-2008:0545)NessusCentOS Local Security Checks
critical
39912openSUSE Security Update : apache2-mod_php5 (apache2-mod_php5-61)NessusSuSE Local Security Checks
critical
38042Mandriva Linux Security Advisory : php (MDVSA-2008:127)NessusMandriva Local Security Checks
critical
37584Mandriva Linux Security Advisory : php (MDVSA-2008:126)NessusMandriva Local Security Checks
critical
36486Mandriva Linux Security Advisory : php (MDVSA-2008:128)NessusMandriva Local Security Checks
critical
34787GLSA-200811-05 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
4620PHP 4.x < 4.4.9 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
33790Mac OS X Multiple Vulnerabilities (Security Update 2008-005)NessusMacOS X Local Security Checks
critical
33575Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : php5 vulnerabilities (USN-628-1)NessusUbuntu Local Security Checks
critical
33524CentOS 3 / 5 : php (CESA-2008:0544)NessusCentOS Local Security Checks
critical
33512RHEL 2.1 : php (RHSA-2008:0546)NessusRed Hat Local Security Checks
critical
33511RHEL 4 : php (RHSA-2008:0545)NessusRed Hat Local Security Checks
critical
33510RHEL 3 / 5 : php (RHSA-2008:0544)NessusRed Hat Local Security Checks
critical
33381openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-5379)NessusSuSE Local Security Checks
critical
33232Fedora 8 : php-5.2.6-2.fc8 (2008-3864)NessusFedora Local Security Checks
critical
33231Fedora 9 : php-5.2.6-2.fc9 (2008-3606)NessusFedora Local Security Checks
critical
32444Slackware 10.2 / 11.0 / 12.0 / 12.1 / current : php (SSA:2008-128-01)NessusSlackware Local Security Checks
critical
32379Debian DSA-1578-1 : php4 - several vulnerabilitiesNessusDebian Local Security Checks
critical
32306Debian DSA-1572-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
critical
4493PHP 5.x < 5.2.6 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
32123PHP < 5.2.6 Multiple VulnerabilitiesNessusCGI abuses
high
801083PHP < 4.4.9 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
801068PHP < 5.2.6 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high