CVE-2008-3659

MEDIUM

Description

Buffer overflow in the memnstr function in PHP 4.4.x before 4.4.9 and PHP 5.6 through 5.2.6 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via the delimiter argument to the explode function. NOTE: the scope of this issue is limited since most applications would not use an attacker-controlled delimiter, but local attacks against safe_mode are feasible.

References

http://bugs.gentoo.org/show_bug.cgi?id=234102

http://lists.apple.com/archives/security-announce/2009/May/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00004.html

http://lists.opensuse.org/opensuse-security-announce/2008-10/msg00006.html

http://marc.info/?l=bugtraq&m=124654546101607&w=2

http://marc.info/?l=bugtraq&m=125631037611762&w=2

http://news.php.net/php.cvs/52002

http://osvdb.org/47483

http://secunia.com/advisories/31982

http://secunia.com/advisories/32148

http://secunia.com/advisories/32316

http://secunia.com/advisories/32746

http://secunia.com/advisories/35074

http://secunia.com/advisories/35650

http://security.gentoo.org/glsa/glsa-200811-05.xml

http://support.apple.com/kb/HT3549

http://wiki.rpath.com/Advisories:rPSA-2009-0035

http://www.debian.org/security/2008/dsa-1647

http://www.mandriva.com/security/advisories?name=MDVSA-2009:021

http://www.mandriva.com/security/advisories?name=MDVSA-2009:022

http://www.mandriva.com/security/advisories?name=MDVSA-2009:023

http://www.mandriva.com/security/advisories?name=MDVSA-2009:024

http://www.openwall.com/lists/oss-security/2008/08/08/2

http://www.openwall.com/lists/oss-security/2008/08/08/3

http://www.openwall.com/lists/oss-security/2008/08/08/4

http://www.openwall.com/lists/oss-security/2008/08/13/8

http://www.php.net/archive/2008.php#id2008-08-07-1

http://www.securityfocus.com/archive/1/501376/100/0/threaded

http://www.securitytracker.com/id?1020995

http://www.us-cert.gov/cas/techalerts/TA09-133A.html

http://www.vupen.com/english/advisories/2008/2336

http://www.vupen.com/english/advisories/2009/1297

https://exchange.xforce.ibmcloud.com/vulnerabilities/44405

Details

Source: MITRE

Published: 2008-08-15

Updated: 2018-10-11

Type: CWE-119

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:N/I:P/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Tenable Plugins

View all (19 total)

IDNameProductFamilySeverity
4779PHP 5.x < 5.2.7 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
41474SuSE 10 Security Update : PHP5 (ZYPP Patch Number 5580)NessusSuSE Local Security Checks
high
39913openSUSE Security Update : apache2-mod_php5 (apache2-mod_php5-168)NessusSuSE Local Security Checks
high
38744Mac OS X 10.5.x < 10.5.7 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
37701Mandriva Linux Security Advisory : php (MDVSA-2009:021)NessusMandriva Local Security Checks
high
36665Ubuntu 6.06 LTS / 7.10 / 8.04 LTS / 8.10 : php5 vulnerabilities (USN-720-1)NessusUbuntu Local Security Checks
critical
36294Mandriva Linux Security Advisory : php (MDVSA-2009:022)NessusMandriva Local Security Checks
critical
35051FreeBSD : php -- multiple vulnerabilities (27d01223-c457-11dd-a721-0030843d3802)NessusFreeBSD Local Security Checks
high
35043PHP 5 < 5.2.7 Multiple VulnerabilitiesNessusCGI abuses
high
35035Slackware 12.0 / 12.1 / current : php (SSA:2008-339-01)NessusSlackware Local Security Checks
high
34787GLSA-200811-05 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
34429SuSE 10 Security Update : PHP5 (ZYPP Patch Number 5661)NessusSuSE Local Security Checks
high
34355Debian DSA-1647-1 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
34233openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-5546)NessusSuSE Local Security Checks
high
4620PHP 4.x < 4.4.9 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
33849PHP < 4.4.9 Multiple VulnerabilitiesNessusCGI abuses
high
5023Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesNessus Network MonitorGeneric
critical
801088PHP 5 < 5.2.7 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
800792Mac OS X 10.5 < 10.5.7 Multiple VulnerabilitiesLog Correlation EngineOperating System Detection
high