PHP < 4.4.9 Multiple Vulnerabilities

high Nessus Plugin ID 33849


The remote web server uses a version of PHP that is affected by multiple issues.


According to its banner, the version of PHP installed on the remote host is older than 4.4.9. Such versions may be affected by several security issues :

- There are unspecified issues in the bundled PCRE library fixed by version 7.7.

- A buffer overflow in the 'imageloadfont()' function in 'ext/gd/gd.c' can be triggered when a specially crafted font is given. (CVE-2008-3658)

- A buffer overflow exists in the internal 'memnstr()' function, which is exposed to userspace as 'explode()'.

- A denial of service vulnerability exists when a filename contains 2 dots. (CVE-2008-3660)

- An 'open_basedir' handling issue in the curl extension.

- 'mbstring.func_overload' set in '.htaccess' becomes global. (CVE-2009-0754)

Note that the release announcement states this will be the last release for the PHP 4.4 series.


Upgrade to PHP version 4.4.9 or later.

See Also

Plugin Details

Severity: High

ID: 33849

File Name: php_4_4_9.nasl

Version: 1.28

Type: remote

Family: CGI abuses

Published: 8/8/2008

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Reference Information

CVE: CVE-2007-4850, CVE-2008-3658, CVE-2008-3659, CVE-2008-3660, CVE-2009-0754

BID: 27413, 30649, 31612, 33542

CWE: 20, 119, 134, 264

SECUNIA: 31409