Debian DSA-3602-1 : php5 - security update

critical Nessus Plugin ID 91615

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were found in PHP, a general-purpose scripting language commonly used for web application development.

The vulnerabilities are addressed by upgrading PHP to the new upstream version 5.6.22, which includes additional bug fixes. Please refer to the upstream changelog for more information :

- https://php.net/ChangeLog-5.php#5.6.21
- https://php.net/ChangeLog-5.php#5.6.22

Solution

Upgrade the php5 packages.

For the stable distribution (jessie), these problems have been fixed in version 5.6.22+dfsg-0+deb8u1.

See Also

https://secure.php.net/ChangeLog-5.php#5.6.21

https://secure.php.net/ChangeLog-5.php#5.6.22

https://packages.debian.org/source/jessie/php5

https://www.debian.org/security/2016/dsa-3602

Plugin Details

Severity: Critical

ID: 91615

File Name: debian_DSA-3602.nasl

Version: 2.10

Type: local

Agent: unix

Published: 6/15/2016

Updated: 1/11/2021

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: High

Score: 7.4

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:php5, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 6/14/2016

Reference Information

CVE: CVE-2013-7456, CVE-2016-3074, CVE-2016-4537, CVE-2016-4538, CVE-2016-4539, CVE-2016-4540, CVE-2016-4541, CVE-2016-4542, CVE-2016-4543, CVE-2016-4544, CVE-2016-5093, CVE-2016-5094, CVE-2016-5095, CVE-2016-5096

DSA: 3602