CVE-2013-7456

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

gd_interpolation.c in the GD Graphics Library (aka libgd) before 2.1.1, as used in PHP before 5.5.36, 5.6.x before 5.6.22, and 7.x before 7.0.7, allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a crafted image that is mishandled by the imagescale function.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.debian.org/security/2016/dsa-3587

http://www.debian.org/security/2016/dsa-3602

http://www.openwall.com/lists/oss-security/2016/05/26/3

http://www.securityfocus.com/bid/90859

http://www.ubuntu.com/usn/USN-3030-1

https://bugs.php.net/bug.php?id=72227

https://github.com/libgd/libgd/commit/4f65a3e4eedaffa1efcf9ee1eb08f0b504fbc31a

https://github.com/php/php-src/commit/7a1aac3343af85b4af4df5f8844946eaa27394ab?w=1

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

Details

Source: MITRE

Published: 2016-08-07

Updated: 2018-01-05

Type: CWE-125

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

CVSS v3

Base Score: 7.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:H

Impact Score: 4.7

Exploitability Score: 2.8

Severity: HIGH

Vulnerable Software

Configuration 1

AND

OR

cpe:2.3:a:libgd:libgd:2.1.0:*:*:*:*:*:*:*

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha1:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha2:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha3:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha4:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha5:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta1:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta2:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta3:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta4:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.6:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.7:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.8:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.9:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.10:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.11:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.12:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.13:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.14:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.15:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.16:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.17:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.18:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.19:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.20:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.21:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.6:*:*:*:*:*:*:*

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
98853PHP 7.0.x < 7.0.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98812PHP 5.6.x < 5.6.22 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
106502pfSense < 2.3.1-p5 Multiple Vulnerabilities (SA-16_07 / SA-16_08)NessusFirewalls
high
93160SUSE SLED12 / SLES12 Security Update : php5 (SUSE-SU-2016:1633-1)NessusSuSE Local Security Checks
critical
92497Mac OS X 10.9.5 and 10.10.5 Multiple Vulnerabilities (Security Update 2016-004)NessusMacOS X Local Security Checks
critical
92496Mac OS X 10.11.x < 10.11.6 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
9393PHP 5.5.x < 5.5.37 / 5.6.x < 5.6.23 / 7.0.x < 7.0.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
802005PHP < 5.5.36, 5.6.22, 7.0.6 GD Graphics Library Out-of-bounds Read IssueLog Correlation EngineWeb Servers
high
92011Ubuntu 12.04 LTS / 14.04 LTS / 15.10 / 16.04 LTS : libgd2 vulnerabilities (USN-3030-1)NessusUbuntu Local Security Checks
critical
91869openSUSE Security Update : php5 (openSUSE-2016-776)NessusSuSE Local Security Checks
critical
91615Debian DSA-3602-1 : php5 - security updateNessusDebian Local Security Checks
critical
91585openSUSE Security Update : php5 (openSUSE-2016-703)NessusSuSE Local Security Checks
critical
91466Amazon Linux AMI : php55 (ALAS-2016-707)NessusAmazon Linux Local Security Checks
high
91465Amazon Linux AMI : php56 (ALAS-2016-706)NessusAmazon Linux Local Security Checks
high
91443PHP 7.0.x < 7.0.7 Multiple VulnerabilitiesNessusCGI abuses
high
91442PHP 5.6.x < 5.6.22 Multiple VulnerabilitiesNessusCGI abuses
high
91441PHP 5.5.x < 5.5.36 Multiple VulnerabilitiesNessusCGI abuses
high
91373FreeBSD : php -- multiple vulnerabilities (6b110175-246d-11e6-8dd3-002590263bf5)NessusFreeBSD Local Security Checks
high
91364Debian DSA-3587-1 : libgd2 - security updateNessusDebian Local Security Checks
high
91355Slackware 14.0 / 14.1 / current : php (SSA:2016-148-03)NessusSlackware Local Security Checks
high