CVE-2016-5093

HIGH

Description

The get_icu_value_internal function in ext/intl/locale/locale_methods.c in PHP before 5.5.36, 5.6.x before 5.6.22, and 7.x before 7.0.7 does not ensure the presence of a '\0' character, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via a crafted locale_get_primary_language call.

References

http://php.net/ChangeLog-5.php

http://php.net/ChangeLog-7.php

http://rhn.redhat.com/errata/RHSA-2016-2750.html

http://www.debian.org/security/2016/dsa-3602

http://www.openwall.com/lists/oss-security/2016/05/26/3

http://www.securityfocus.com/bid/90946

https://bugs.php.net/bug.php?id=72241

https://github.com/php/php-src/commit/97eff7eb57fc2320c267a949cffd622c38712484?w=1

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

Details

Source: MITRE

Published: 2016-08-07

Updated: 2018-01-05

Type: CWE-125

Risk Information

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3.0

Base Score: 8.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Impact Score: 4.7

Exploitability Score: 3.9

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.5.35 (inclusive)

cpe:2.3:a:php:php:5.6.0:alpha1:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha2:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha3:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha4:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:alpha5:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta1:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta2:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta3:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.0:beta4:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.6:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.7:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.8:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.9:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.10:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.11:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.12:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.13:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.14:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.15:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.16:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.17:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.18:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.19:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.20:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.6.21:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:7.0.6:*:*:*:*:*:*:*

Tenable Plugins

View all (28 total)

IDNameProductFamilySeverity
137966EulerOS Virtualization 3.0.6.0 : php (EulerOS-SA-2020-1747)NessusHuawei Local Security Checks
critical
132184EulerOS 2.0 SP3 : php (EulerOS-SA-2019-2649)NessusHuawei Local Security Checks
critical
131592EulerOS 2.0 SP2 : php (EulerOS-SA-2019-2438)NessusHuawei Local Security Checks
critical
130683EulerOS 2.0 SP5 : php (EulerOS-SA-2019-2221)NessusHuawei Local Security Checks
critical
98853PHP 7.0.x < 7.0.7 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98812PHP 5.6.x < 5.6.22 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
106502pfSense < 2.3.1-p5 Multiple Vulnerabilities (SA-16_07 / SA-16_08)NessusFirewalls
high
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
93160SUSE SLED12 / SLES12 Security Update : php5 (SUSE-SU-2016:1633-1)NessusSuSE Local Security Checks
high
92699Ubuntu 12.04 LTS / 14.04 LTS / 16.04 LTS : php5, php7.0 vulnerabilities (USN-3045-1) (httpoxy)NessusUbuntu Local Security Checks
high
92497Mac OS X 10.9.5 and 10.10.5 Multiple Vulnerabilities (Security Update 2016-004)NessusMacOS X Local Security Checks
critical
92496Mac OS X 10.11.x < 10.11.6 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
critical
92149Fedora 24 : php (2016-b967ac1a74)NessusFedora Local Security Checks
high
92106Fedora 23 : php (2016-6b1938566f)NessusFedora Local Security Checks
high
92104Fedora 22 : php (2016-65f1ffdc0c)NessusFedora Local Security Checks
high
9393PHP 5.5.x < 5.5.37 / 5.6.x < 5.6.23 / 7.0.x < 7.0.8 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high
91900Debian DLA-533-1 : php5 security updateNessusDebian Local Security Checks
high
91869openSUSE Security Update : php5 (openSUSE-2016-776)NessusSuSE Local Security Checks
high
91665SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1581-1)NessusSuSE Local Security Checks
critical
91615Debian DSA-3602-1 : php5 - security updateNessusDebian Local Security Checks
high
91585openSUSE Security Update : php5 (openSUSE-2016-703)NessusSuSE Local Security Checks
high
91466Amazon Linux AMI : php55 (ALAS-2016-707)NessusAmazon Linux Local Security Checks
high
91465Amazon Linux AMI : php56 (ALAS-2016-706)NessusAmazon Linux Local Security Checks
high
91443PHP 7.0.x < 7.0.7 Multiple VulnerabilitiesNessusCGI abuses
high
91442PHP 5.6.x < 5.6.22 Multiple VulnerabilitiesNessusCGI abuses
high
91441PHP 5.5.x < 5.5.36 Multiple VulnerabilitiesNessusCGI abuses
high
91373FreeBSD : php -- multiple vulnerabilities (6b110175-246d-11e6-8dd3-002590263bf5)NessusFreeBSD Local Security Checks
high
91355Slackware 14.0 / 14.1 / current : php (SSA:2016-148-03)NessusSlackware Local Security Checks
high