PHP < 5.2.5 Multiple Vulnerabilities

Medium Nessus Plugin ID 28181

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 5.2.5. Such versions may be affected by various issues, including but not limited to several buffer overflows.

Solution

Upgrade to PHP version 5.2.5 or later.

See Also

http://www.php.net/releases/5_2_5.php

Plugin Details

Severity: Medium

ID: 28181

File Name: php_5_2_5.nasl

Version: 1.20

Type: remote

Family: CGI abuses

Published: 2007/11/12

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.4

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2007/09/10

Reference Information

CVE: CVE-2007-3996, CVE-2007-4782, CVE-2007-4783, CVE-2007-4784, CVE-2007-4825, CVE-2007-4840, CVE-2007-4887, CVE-2007-4889, CVE-2007-5447, CVE-2007-5653, CVE-2007-5898, CVE-2007-5899, CVE-2007-5900, CVE-2008-2107, CVE-2008-2108, CVE-2008-4107

BID: 26403, 69246

CWE: 20, 22, 78, 94, 189, 200, 264