CVE-2007-4782

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PHP before 5.2.3 allows context-dependent attackers to cause a denial of service (application crash) via (1) a long string in the pattern parameter to the glob function; or (2) a long string in the string parameter to the fnmatch function, accompanied by a pattern parameter value with undefined characteristics, as demonstrated by a "*[1]e" value. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless these issues can be demonstrated for code execution.

References

http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html

http://osvdb.org/38686

http://secunia.com/advisories/27102

http://secunia.com/advisories/28658

http://secunia.com/advisories/30828

http://secunia.com/advisories/31119

http://secunia.com/advisories/31200

http://securityreason.com/securityalert/3109

http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml

http://www.mandriva.com/security/advisories?name=MDVSA-2009:022

http://www.mandriva.com/security/advisories?name=MDVSA-2009:023

http://www.redhat.com/support/errata/RHSA-2008-0505.html

http://www.redhat.com/support/errata/RHSA-2008-0544.html

http://www.redhat.com/support/errata/RHSA-2008-0545.html

http://www.redhat.com/support/errata/RHSA-2008-0582.html

http://www.securityfocus.com/archive/1/478626/100/0/threaded

http://www.securityfocus.com/archive/1/478630/100/0/threaded

http://www.securityfocus.com/archive/1/478726/100/0/threaded

http://www.ubuntu.com/usn/usn-628-1

https://exchange.xforce.ibmcloud.com/vulnerabilities/36457

https://exchange.xforce.ibmcloud.com/vulnerabilities/36461

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10897

https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00773.html

Details

Source: MITRE

Published: 2007-09-10

Updated: 2018-10-15

Type: CWE-94

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.2.3 (inclusive)

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
79606F5 Networks BIG-IP : GNU C Library vulnerability (SOL15885)NessusF5 Networks Local Security Checks
critical
67712Oracle Linux 4 : php (ELSA-2008-0545)NessusOracle Linux Local Security Checks
critical
67711Oracle Linux 3 / 5 : php (ELSA-2008-0544)NessusOracle Linux Local Security Checks
critical
60445Scientific Linux Security Update : php on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
60444Scientific Linux Security Update : php on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
critical
43693CentOS 4 : php (CESA-2008:0545)NessusCentOS Local Security Checks
critical
41187SuSE9 Security Update : PHP4 (YOU Patch Number 12049)NessusSuSE Local Security Checks
high
36294Mandriva Linux Security Advisory : php (MDVSA-2009:022)NessusMandriva Local Security Checks
critical
33575Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : php5 vulnerabilities (USN-628-1)NessusUbuntu Local Security Checks
critical
33524CentOS 3 / 5 : php (CESA-2008:0544)NessusCentOS Local Security Checks
critical
33511RHEL 4 : php (RHSA-2008:0545)NessusRed Hat Local Security Checks
critical
33510RHEL 3 / 5 : php (RHSA-2008:0544)NessusRed Hat Local Security Checks
critical
33232Fedora 8 : php-5.2.6-2.fc8 (2008-3864)NessusFedora Local Security Checks
critical
30092openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4909)NessusSuSE Local Security Checks
high
29878openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4810)NessusSuSE Local Security Checks
high
29780SuSE 10 Security Update : PHP5 (ZYPP Patch Number 4808)NessusSuSE Local Security Checks
high
28181PHP < 5.2.5 Multiple VulnerabilitiesNessusCGI abuses
medium
26942GLSA-200710-02 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high