CVE-2007-4840

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PHP 5.2.4 and earlier allows context-dependent attackers to cause a denial of service (application crash) via (1) a long string in the out_charset parameter to the iconv function; or a long string in the charset parameter to the (2) iconv_mime_decode_headers, (3) iconv_mime_decode, or (4) iconv_strlen function. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless these issues can be demonstrated for code execution.

References

http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html

http://osvdb.org/38916

http://secunia.com/advisories/27102

http://secunia.com/advisories/27659

http://secunia.com/advisories/28658

http://secunia.com/advisories/30040

http://securityreason.com/securityalert/3122

http://wiki.rpath.com/wiki/Advisories:rPSA-2007-0242

http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml

http://www.securityfocus.com/archive/1/478730/100/0/threaded

http://www.securityfocus.com/archive/1/491693/100/0/threaded

https://issues.rpath.com/browse/RPL-1943

Details

Source: MITRE

Published: 2007-09-12

Updated: 2018-10-15

Type: CWE-20

Risk Information

CVSS v2

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.2.4 (inclusive)

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
41187SuSE9 Security Update : PHP4 (YOU Patch Number 12049)NessusSuSE Local Security Checks
high
30092openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4909)NessusSuSE Local Security Checks
high
29878openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4810)NessusSuSE Local Security Checks
high
29780SuSE 10 Security Update : PHP5 (ZYPP Patch Number 4808)NessusSuSE Local Security Checks
high
28181PHP < 5.2.5 Multiple VulnerabilitiesNessusCGI abuses
medium
26942GLSA-200710-02 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high