CVE-2007-4825

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Directory traversal vulnerability in PHP 5.2.4 and earlier allows attackers to bypass open_basedir restrictions and possibly execute arbitrary code via a .. (dot dot) in the dl function.

References

http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html

http://osvdb.org/45902

http://secunia.com/advisories/27102

http://secunia.com/advisories/28658

http://securityreason.com/securityalert/3119

http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml

http://www.php.net/ChangeLog-5.php#5.2.5

http://www.php.net/releases/5_2_5.php

http://www.securityfocus.com/archive/1/478985/100/0/threaded

http://www.securityfocus.com/archive/1/478988/100/0/threaded

http://www.securityfocus.com/archive/1/478989/100/0/threaded

https://exchange.xforce.ibmcloud.com/vulnerabilities/36528

Details

Source: MITRE

Published: 2007-09-12

Updated: 2018-10-15

Type: CWE-22

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.2.3 (inclusive)

Tenable Plugins

View all (7 total)

IDNameProductFamilySeverity
41187SuSE9 Security Update : PHP4 (YOU Patch Number 12049)NessusSuSE Local Security Checks
high
30092openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4909)NessusSuSE Local Security Checks
high
29878openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4810)NessusSuSE Local Security Checks
high
29780SuSE 10 Security Update : PHP5 (ZYPP Patch Number 4808)NessusSuSE Local Security Checks
high
28181PHP < 5.2.5 Multiple VulnerabilitiesNessusCGI abuses
medium
26942GLSA-200710-02 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
high
4281PHP 5.x < 5.2.5 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
high