CVE-2007-5898

MEDIUM

Description

The (1) htmlentities and (2) htmlspecialchars functions in PHP before 5.2.5 accept partial multibyte sequences, which has unknown impact and attack vectors, a different issue than CVE-2006-5465.

References

http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html

http://secunia.com/advisories/27648

http://secunia.com/advisories/27659

http://secunia.com/advisories/27864

http://secunia.com/advisories/28249

http://secunia.com/advisories/28658

http://secunia.com/advisories/30040

http://secunia.com/advisories/30828

http://secunia.com/advisories/31119

http://secunia.com/advisories/31124

http://secunia.com/advisories/31200

http://securitytracker.com/id?1018934

http://wiki.rpath.com/wiki/Advisories:rPSA-2007-0242

http://www.debian.org/security/2008/dsa-1444

http://www.mandriva.com/security/advisories?name=MDVSA-2008:125

http://www.mandriva.com/security/advisories?name=MDVSA-2008:126

http://www.mandriva.com/security/advisories?name=MDVSA-2008:127

http://www.php.net/ChangeLog-5.php#5.2.5

http://www.php.net/releases/5_2_5.php

http://www.redhat.com/support/errata/RHSA-2008-0505.html

http://www.redhat.com/support/errata/RHSA-2008-0544.html

http://www.redhat.com/support/errata/RHSA-2008-0545.html

http://www.redhat.com/support/errata/RHSA-2008-0546.html

http://www.redhat.com/support/errata/RHSA-2008-0582.html

http://www.securityfocus.com/archive/1/491693/100/0/threaded

http://www.ubuntu.com/usn/usn-549-2

http://www.ubuntu.com/usn/usn-628-1

https://issues.rpath.com/browse/RPL-1943

https://launchpad.net/bugs/173043

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10080

https://usn.ubuntu.com/549-1/

https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00773.html

Details

Source: MITRE

Published: 2007-11-20

Updated: 2018-10-15

Risk Information

CVSS v2.0

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:N

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:php:php:*:*:*:*:*:*:*:* versions up to 5.2.4 (inclusive)

Tenable Plugins

View all (21 total)

IDNameProductFamilySeverity
67712Oracle Linux 4 : php (ELSA-2008-0545)NessusOracle Linux Local Security Checks
critical
67711Oracle Linux 3 / 5 : php (ELSA-2008-0544)NessusOracle Linux Local Security Checks
critical
60445Scientific Linux Security Update : php on SL5.x i386/x86_64NessusScientific Linux Local Security Checks
critical
60444Scientific Linux Security Update : php on SL4.x i386/x86_64NessusScientific Linux Local Security Checks
critical
43693CentOS 4 : php (CESA-2008:0545)NessusCentOS Local Security Checks
critical
41187SuSE9 Security Update : PHP4 (YOU Patch Number 12049)NessusSuSE Local Security Checks
high
38042Mandriva Linux Security Advisory : php (MDVSA-2008:127)NessusMandriva Local Security Checks
critical
37584Mandriva Linux Security Advisory : php (MDVSA-2008:126)NessusMandriva Local Security Checks
critical
33575Ubuntu 6.06 LTS / 7.04 / 7.10 / 8.04 LTS : php5 vulnerabilities (USN-628-1)NessusUbuntu Local Security Checks
critical
33524CentOS 3 / 5 : php (CESA-2008:0544)NessusCentOS Local Security Checks
critical
33512RHEL 2.1 : php (RHSA-2008:0546)NessusRed Hat Local Security Checks
critical
33511RHEL 4 : php (RHSA-2008:0545)NessusRed Hat Local Security Checks
critical
33510RHEL 3 / 5 : php (RHSA-2008:0544)NessusRed Hat Local Security Checks
critical
33232Fedora 8 : php-5.2.6-2.fc8 (2008-3864)NessusFedora Local Security Checks
critical
30092openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4909)NessusSuSE Local Security Checks
high
29878openSUSE 10 Security Update : apache2-mod_php5 (apache2-mod_php5-4810)NessusSuSE Local Security Checks
high
29838Debian DSA-1444-2 : php5 - several vulnerabilitiesNessusDebian Local Security Checks
high
29780SuSE 10 Security Update : PHP5 (ZYPP Patch Number 4808)NessusSuSE Local Security Checks
high
29213Ubuntu 7.10 : php5 regression (USN-549-2)NessusUbuntu Local Security Checks
high
28372Ubuntu 6.06 LTS / 6.10 / 7.04 / 7.10 : php5 vulnerabilities (USN-549-1)NessusUbuntu Local Security Checks
high
28181PHP < 5.2.5 Multiple VulnerabilitiesNessusCGI abuses
medium