pfSense < 2.3.5 Multiple Vulnerabilities (KRACK)

Critical Nessus Plugin ID 109037

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is affected by multiple vulnerabilities as stated in the referenced vendor advisories.

Solution

Upgrade to pfSense version 2.3.5 or later.

See Also

https://doc.pfsense.org/index.php/2.3.5_New_Features_and_Changes

http://www.nessus.org/u?ee52d9a2

http://www.nessus.org/u?e1b23834

https://www.krackattacks.com/

Plugin Details

Severity: Critical

ID: 109037

File Name: pfsense_2_3_5.nasl

Version: 1.5

Type: remote

Family: Firewalls

Published: 2018/04/13

Modified: 2018/07/13

Dependencies: 106952

Risk Information

Risk Factor: Critical

CVSS Score Source: manual

CVSS Score Rationale: Score from a more in depth analysis done by tenable.

CVSSv2

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:ND

CVSSv3

Base Score: 9.3

Temporal Score: 8.4

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:X

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Patch Publication Date: 2017/10/19

Vulnerability Publication Date: 2017/09/02

Reference Information

CVE: CVE-2017-12837, CVE-2017-12883, CVE-2017-13077, CVE-2017-13078, CVE-2017-13079, CVE-2017-13080, CVE-2017-13081, CVE-2017-13082, CVE-2017-13084, CVE-2017-13086, CVE-2017-13087, CVE-2017-13088, CVE-2017-13704, CVE-2017-14491, CVE-2017-14492, CVE-2017-14493, CVE-2017-14494, CVE-2017-14495, CVE-2017-14496

BID: 103513, 100852, 100860, 101274

IAVA: 2017-A-0284, 2017-A-0310

FreeBSD: SA-17:07.wpa