CVE-2017-14493

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Stack-based buffer overflow in dnsmasq before 2.78 allows remote attackers to cause a denial of service (crash) or execute arbitrary code via a crafted DHCPv6 request.

References

http://lists.opensuse.org/opensuse-security-announce/2017-10/msg00006.html

http://nvidia.custhelp.com/app/answers/detail/a_id/4561

http://thekelleys.org.uk/dnsmasq/CHANGELOG

http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=3d4ff1ba8419546490b464418223132529514033

http://www.arubanetworks.com/assets/alert/ARUBA-PSA-2017-005.txt

http://www.debian.org/security/2017/dsa-3989

http://www.securityfocus.com/bid/101085

http://www.securitytracker.com/id/1039474

http://www.ubuntu.com/usn/USN-3430-1

http://www.ubuntu.com/usn/USN-3430-2

https://access.redhat.com/errata/RHSA-2017:2836

https://access.redhat.com/errata/RHSA-2017:2837

https://access.redhat.com/security/vulnerabilities/3199382

https://security.gentoo.org/glsa/201710-27

https://security.googleblog.com/2017/10/behind-masq-yet-more-dns-and-dhcp.html

https://www.exploit-db.com/exploits/42943/

https://www.kb.cert.org/vuls/id/973527

https://www.mail-archive.com/[email protected]/msg11664.html

https://www.mail-archive.com/[email protected]/msg11665.html

https://www.synology.com/support/security/Synology_SA_17_59_Dnsmasq

Details

Source: MITRE

Published: 2017-10-03

Updated: 2018-03-04

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Tenable Plugins

View all (28 total)

IDNameProductFamilySeverity
126963Amazon Linux 2 : dnsmasq (ALAS-2019-1251)NessusAmazon Linux Local Security Checks
critical
124926EulerOS Virtualization 3.0.1.0 : dnsmasq (EulerOS-SA-2019-1423)NessusHuawei Local Security Checks
critical
124883EulerOS Virtualization for ARM 64 3.0.1.0 : dnsmasq (EulerOS-SA-2019-1380)NessusHuawei Local Security Checks
critical
121733Photon OS 1.0: Dnsmasq PHSA-2017-0035NessusPhotonOS Local Security Checks
critical
111884Photon OS 1.0: Dnsmasq PHSA-2017-0035 (deprecated)NessusPhotonOS Local Security Checks
high
109037pfSense < 2.3.5 Multiple Vulnerabilities (KRACK)NessusFirewalls
critical
105901Fedora 27 : dnsmasq (2017-7106a157f5)NessusFedora Local Security Checks
critical
104110Fedora 25 : dnsmasq (2017-515264ae24)NessusFedora Local Security Checks
critical
104070GLSA-201710-27 : Dnsmasq: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
103888Fedora 26 : dnsmasq (2017-24f067299e)NessusFedora Local Security Checks
critical
103821EulerOS 2.0 SP2 : dnsmasq (EulerOS-SA-2017-1240)NessusHuawei Local Security Checks
critical
103820EulerOS 2.0 SP1 : dnsmasq (EulerOS-SA-2017-1239)NessusHuawei Local Security Checks
critical
103647dnsmasq < 2.78 Multiple Remote VulnerabilitiesNessusDNS
critical
103641Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : dnsmasq vulnerabilities (USN-3430-1)NessusUbuntu Local Security Checks
critical
103640SUSE SLES11 Security Update : dnsmasq (SUSE-SU-2017:2619-1)NessusSuSE Local Security Checks
critical
103639SUSE SLED12 / SLES12 Security Update : dnsmasq (SUSE-SU-2017:2618-1)NessusSuSE Local Security Checks
critical
103638SUSE SLES11 Security Update : dnsmasq (SUSE-SU-2017:2617-1)NessusSuSE Local Security Checks
critical
103637SUSE SLES12 Security Update : dnsmasq (SUSE-SU-2017:2616-1)NessusSuSE Local Security Checks
critical
103635Scientific Linux Security Update : dnsmasq on SL7.x x86_64 (20171002)NessusScientific Linux Local Security Checks
critical
103629RHEL 7 : dnsmasq (RHSA-2017:2837)NessusRed Hat Local Security Checks
critical
103628RHEL 7 : dnsmasq (RHSA-2017:2836)NessusRed Hat Local Security Checks
critical
103625Oracle Linux 7 : dnsmasq (ELSA-2017-2836)NessusOracle Linux Local Security Checks
critical
103623openSUSE Security Update : dnsmasq (openSUSE-2017-1116)NessusSuSE Local Security Checks
critical
103620FreeBSD : dnsmasq -- multiple vulnerabilities (b77b5646-a778-11e7-ac58-b499baebfeaf)NessusFreeBSD Local Security Checks
critical
103608Debian DSA-3989-1 : dnsmasq - security updateNessusDebian Local Security Checks
critical
103605CentOS 7 : dnsmasq (CESA-2017:2836)NessusCentOS Local Security Checks
critical
103604Amazon Linux AMI : dnsmasq (ALAS-2017-907)NessusAmazon Linux Local Security Checks
critical
103599Slackware 13.0 / 13.1 / 13.37 / 14.0 / 14.1 / 14.2 / current : dnsmasq (SSA:2017-275-01)NessusSlackware Local Security Checks
critical