CVE-2017-12883

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Buffer overflow in the S_grok_bslash_N function in regcomp.c in Perl 5 before 5.24.3-RC1 and 5.26.x before 5.26.1-RC1 allows remote attackers to disclose sensitive information or cause a denial of service (application crash) via a crafted regular expression with an invalid '\N{U+...}' escape.

References

http://mirror.cucumberlinux.com/cucumber/cucumber-1.0/source/lang-base/perl/patches/CVE-2017-12883.patch

http://www.debian.org/security/2017/dsa-3982

http://www.securityfocus.com/bid/100852

https://bugzilla.redhat.com/show_bug.cgi?id=1492093

https://perl5.git.perl.org/perl.git/commitdiff/2be4edede4ae226e2eebd4eff28cedd2041f300f#patch1

https://perl5.git.perl.org/perl.git/log/refs/tags/v5.24.3-RC1

https://perl5.git.perl.org/perl.git/log/refs/tags/v5.26.1-RC1

https://rt.perl.org/Public/Bug/Display.html?id=131598

https://security.netapp.com/advisory/ntap-20180426-0001/

https://www.oracle.com/security-alerts/cpujul2020.html

Details

Source: MITRE

Published: 2017-09-19

Updated: 2020-07-15

Type: CWE-119

Risk Information

CVSS v2

Base Score: 6.4

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:P

Impact Score: 4.9

Exploitability Score: 10

Severity: MEDIUM

CVSS v3

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Impact Score: 5.2

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:perl:perl:*:*:*:*:*:*:*:* versions up to 5.24.2 (inclusive)

cpe:2.3:a:perl:perl:5.26.0:*:*:*:*:*:*:*

Tenable Plugins

View all (12 total)

IDNameProductFamilySeverity
121735Photon OS 1.0: Perl PHSA-2017-0037NessusPhotonOS Local Security Checks
critical
111886Photon OS 1.0: Perl / Ruby PHSA-2017-0037 (deprecated)NessusPhotonOS Local Security Checks
critical
109037pfSense < 2.3.5 Multiple Vulnerabilities (KRACK)NessusFirewalls
critical
106092SUSE SLES12 Security Update : CaaS Platform 2.0 images (SUSE-SU-2018:0053-1)NessusSuSE Local Security Checks
critical
105911Fedora 27 : 4:perl (2017-7ae07e9f1f)NessusFedora Local Security Checks
critical
104783SUSE SLED12 / SLES12 Security Update : perl (SUSE-SU-2017:3092-1)NessusSuSE Local Security Checks
critical
104767openSUSE Security Update : perl (openSUSE-2017-1304)NessusSuSE Local Security Checks
critical
104543Ubuntu 14.04 LTS / 16.04 LTS / 17.04 : perl vulnerabilities (USN-3478-1)NessusUbuntu Local Security Checks
critical
103886Fedora 25 : 4:perl (2017-2008fdd7e2)NessusFedora Local Security Checks
critical
103613Fedora 26 : 4:perl (2017-89492f7161)NessusFedora Local Security Checks
critical
103442FreeBSD : perl -- multiple vulnerabilities (d9e82328-a129-11e7-987e-4f174049b30a)NessusFreeBSD Local Security Checks
critical
103392Debian DSA-3982-1 : perl - security updateNessusDebian Local Security Checks
critical