pfSense < 2.2.3 Multiple Vulnerabilities (SA-15_07) (Logjam)

Critical Nessus Plugin ID 106495

Synopsis

The remote firewall host is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the remote pfSense install is prior to 2.2.3. It is, therefore, affected by multiple vulnerabilities as stated in the referenced vendor advisories.

Solution

Upgrade to pfSense version 2.2.3 or later.

See Also

https://doc.pfsense.org/index.php/2.2.3_New_Features_and_Changes

http://www.nessus.org/u?61bea99f

Plugin Details

Severity: Critical

ID: 106495

File Name: pfsense_SA-15_06.nasl

Version: 1.7

Type: remote

Family: Firewalls

Published: 2018/01/31

Modified: 2018/07/24

Dependencies: 106952

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:pfsense:pfsense, cpe:/a:bsdperimeter:pfsense

Required KB Items: Host/pfSense

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/06/25

Vulnerability Publication Date: 2015/06/25

Reference Information

CVE: CVE-2014-8176, CVE-2015-1788, CVE-2015-1789, CVE-2015-1790, CVE-2015-1791, CVE-2015-1792, CVE-2015-2325, CVE-2015-2326, CVE-2015-3414, CVE-2015-3415, CVE-2015-3416, CVE-2015-4000, CVE-2015-4029, CVE-2015-4171, CVE-2015-4598, CVE-2015-4642, CVE-2015-4643, CVE-2015-4644, CVE-2015-6508, CVE-2015-6509, CVE-2015-6510, CVE-2015-6511

BID: 74228, 75174, 75175, 75244, 75290, 75291, 75292

FreeBSD: SA-15:10.openssl