PHP 7.0.x < 7.0.7 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 98853

Synopsis

PHP 7.0.x < 7.0.7 Multiple Vulnerabilities

Description

According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.7. It is, therefore, affected by multiple vulnerabilities :

- An out-of-bounds read error exists in the _gdContributionsCalc() function within file ext/gd/libgd/gd_interpolation.c. An unauthenticated, remote attacker can exploit this to disclose sensitive information or crash the process linked against the library. (CVE-2013-7456)

- An out-of-bounds read error exists in the get_icu_value_internal() function within file ext/intl/locale/locale_methods.c due to improper handling of user-supplied input. An unauthenticated, remote attacker can exploit this to disclose sensitive information or crash the process linked against the
library. (CVE-2016-5093)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.0.7 or later.

See Also

http://php.net/ChangeLog-7.php#7.0.7

Plugin Details

Severity: High

ID: 98853

Type: remote

Published: 2019/01/09

Updated: 2019/04/10

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

0
0

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2016/05/26

Vulnerability Publication Date: 2013/09/24

Reference Information

CVE: CVE-2013-7456, CVE-2016-5093

BID: 90946

CWE: 125

OWASP: 2013-A9, 2017-A9