WordPress 5.6.x < 5.6.3 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 112753
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


WordPress 5.6.x < 5.6.3 Multiple Vulnerabilities


According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- An XML External Entity (XXE) vulnerability exists in the media library affecting PHP 8.

- A data exposure vulnerability exists in the REST API.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to WordPress version 5.6.3 or latest.

See Also



Plugin Details

Severity: Medium

ID: 112753

Type: remote

Published: 4/16/2021

Updated: 10/11/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2021-29447


Risk Factor: Medium

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N


Risk Factor: Medium

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/15/2020

Vulnerability Publication Date: 4/15/2021

Reference Information

CVE: CVE-2021-29447, CVE-2021-29450