CVE-2021-29447

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Wordpress is an open source CMS. A user with the ability to upload files (like an Author) can exploit an XML parsing issue in the Media Library leading to XXE attacks. This requires WordPress installation to be using PHP 8. Access to internal files is possible in a successful XXE attack. This has been patched in WordPress version 5.7.1, along with the older affected versions via a minor release. We strongly recommend you keep auto-updates enabled.

References

https://wordpress.org/news/category/security/

https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-rv47-pc52-qrhh

https://lists.debian.org/debian-lts-announce/2021/04/msg00017.html

https://www.debian.org/security/2021/dsa-4896

http://packetstormsecurity.com/files/163148/XML-External-Entity-Via-MP3-File-Upload-On-WordPress.html

http://packetstormsecurity.com/files/164198/WordPress-5.7-Media-Library-XML-Injection.html

Details

Source: MITRE

Published: 2021-04-15

Updated: 2021-09-20

Type: CWE-611

Risk Information

CVSS v2

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8

Severity: MEDIUM

CVSS v3

Base Score: 6.5

Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Impact Score: 3.6

Exploitability Score: 2.8

Severity: MEDIUM

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
148963Debian DSA-4896-1 : wordpress - security updateNessusDebian Local Security Checks
medium
148927Debian DLA-2630-1 : wordpress security updateNessusDebian Local Security Checks
medium
148844WordPress 5.7 < 5.7.1 / 5.6 < 5.6.3 / 5.5 < 5.5.4 / 5.4 < 5.4.5 / 5.3 < 5.3.7 / 5.2 < 5.2.10 / 5.1 < 5.1.9 / 5.0 < 5.0.12 / 4.9 < 4.9.17 / 4.8 < 4.8.16 / 4.7 < 4.7.20NessusCGI abuses
medium