WordPress 5.1.x < 5.1.9 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 112748

Language:

Synopsis

WordPress 5.1.x < 5.1.9 Multiple Vulnerabilities

Description

According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- An XML External Entity (XXE) vulnerability exists in the media library affecting PHP 8.

- A data exposure vulnerability exists in the REST API.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Update to WordPress version 5.1.9 or latest.

See Also

https://wordpress.org/news/2021/04/wordpress-5-7-1-security-and-maintenance-release/

https://wordpress.org/support/wordpress-version/version-5-1-9/

Plugin Details

Severity: Medium

ID: 112748

Type: remote

Published: 4/16/2021

Updated: 10/11/2021

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: Medium

Score: 4.4

CVSS v2

Risk Factor: Medium

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:N/A:N

CVSS Score Source: CVE-2021-29447

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

CVSS Score Source: CVE-2021-29447

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/15/2020

Vulnerability Publication Date: 4/15/2021

Reference Information

CVE: CVE-2021-29447, CVE-2021-29450