Oracle MySQL 5.6.x < 5.6.27 Multiple DoS

Critical Nessus Network Monitor Plugin ID 9236

Synopsis

The remote database server is vulnerable to multiple Denial of Service (DoS) attack vectors.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.27 and is affected by multiple unspecified flaws related the following subcomponents :
- Security:Firewall (CVE-2015-4766)
- Security:Privileges (CVE-2015-4791)
- Server Optimizer (CVE-2015-4800)
- Server Partition (CVE-2015-4833)
- DML (CVE-2015-4862, CVE-2015-4905)
- InnoDB (CVE-2015-4866, CVE-2015-4895)
- Replication (CVE-2015-4890)
- libmysqld (CVE-2015-4904)
- Memcached (CVE-2015-4910)

These flaws may allow an authenticated attacker to cause a denial of service.

Addditionally, an unspecified vulnerability flaw allows remote authenticated users to affect availability via unknown vectors related to Types. No further detailes have been provided by the vendor about these vulnerabilities.

Solution

Upgrade to MySQL 5.6.27 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-27.html

Plugin Details

Severity: Critical

ID: 9236

Family: Database

Published: 2016/04/15

Modified: 2018/09/16

Dependencies: 8914

Nessus ID: 86547

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/10/20

Vulnerability Publication Date: 2015/10/20

Reference Information

CVE: CVE-2015-4730, CVE-2015-4766, CVE-2015-4791, CVE-2015-4800, CVE-2015-4833, CVE-2015-4862, CVE-2015-4866, CVE-2015-4890, CVE-2015-4895, CVE-2015-4904, CVE-2015-4905, CVE-2015-4910