WordPress < 3.7.4 / 3.8.x < 3.8.4 / 3.9.x < 3.9.2 Multiple Vulnerabilities
High Nessus Network Monitor Plugin ID 9025
SynopsisThe remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.
DescriptionVersions of WordPress 3.7.x prior to 3.7.4 , 3.8.x prior to 3.8.4 , and 3.9.x prior to 3.9.2 are susceptible to the following vulnerabilities :
- An XML injection flaw exists within 'getid3.lib.php' due to the parser accepting XML external entities from untrusted sources. Using specially crafted XML data, a remote attacker could access sensitive information or cause a denial of service. This affects versions 3.6 - 3.9.1, except 3.7.4 and 3.8.4. (OSVDB 104475)
- An XML injection flaw exists within 'xmlrpc.php' due to the parser accepting XML internal entities without properly validating them. Using specially crafted XML data, a remote attacker could cause a denial of service. This affects versions 1.5 - 3.9.1, except 3.7.4 and 3.8.4. (OSVDB 109867)
- An unsafe serialization flaw exists in the script '/src/wp-includes/class-wp-customize-widgets.php' when processing widgets. This could allow a remote attacker to execute arbitrary code. Versions 3.9 and 3.9.1 non-default configurations are affected. (OSVDB 109868)
- A flaw exists when building CSRF tokens due to it not separating pieces by delimiter and not comparing nonces in a time-constant manner. This could allow a remote attacker to conduct a brute force attack and potentially disclose the CSRF token. This affects versions 2.0.3 - 3.9.1, except 3.7.4 and 3.8.4. (OSVDB 109869)
- A cross-site scripting flaw exists in the function 'get_avatar' within the '/src/wp-includes/pluggable.php' script where input from the avatars is not validated before returning it to the user. Using a specially crafted request, an authenticated attacker could execute arbitrary script code within the browser / server trust relationship. This affects version 3.9.1. (OSVDB 109870)
SolutionUpgrade to WordPress 3.9.2, or later. If 3.9.x cannot be obtained, 3.8.4, and 3.7.4 are also patched for these vulnerabilities.