CVE-2014-5204

MEDIUM
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

wp-includes/pluggable.php in WordPress before 3.9.2 rejects invalid CSRF nonces with a different timing depending on which characters in the nonce are incorrect, which makes it easier for remote attackers to bypass a CSRF protection mechanism via a brute-force attack.

References

http://openwall.com/lists/oss-security/2014/08/13/3

http://www.debian.org/security/2014/dsa-3001

https://core.trac.wordpress.org/changeset/29384

https://wordpress.org/news/2014/08/wordpress-3-9-2/

Details

Source: MITRE

Published: 2014-08-18

Updated: 2015-11-25

Type: CWE-352

Risk Information

CVSS v2

Base Score: 6.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 8.6

Severity: MEDIUM

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
9025WordPress < 3.7.4 / 3.8.x < 3.8.4 / 3.9.x < 3.9.2 Multiple VulnerabilitiesNessus Network MonitorCGI
high
82202Debian DLA-56-1 : wordpress security updateNessusDebian Local Security Checks
high
77347Fedora 19 : wordpress-3.9.2-3.fc19 (2014-9270)NessusFedora Local Security Checks
high
77312Fedora 20 : wordpress-3.9.2-3.fc20 (2014-9264)NessusFedora Local Security Checks
high
77157WordPress < 3.7.4 / 3.8.4 / 3.9.2 Multiple VulnerabilitiesNessusCGI abuses
high
77102Debian DSA-3001-1 : wordpress - security updateNessusDebian Local Security Checks
high