CVE-2014-5240

LOW
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

Cross-site scripting (XSS) vulnerability in wp-includes/pluggable.php in WordPress before 3.9.2, when Multisite is enabled, allows remote authenticated administrators to inject arbitrary web script or HTML, and obtain Super Admin privileges, via a crafted avatar URL.

References

http://openwall.com/lists/oss-security/2014/08/13/3

http://www.debian.org/security/2014/dsa-3001

https://core.trac.wordpress.org/changeset/29398

https://wordpress.org/news/2014/08/wordpress-3-9-2/

Details

Source: MITRE

Published: 2014-08-18

Updated: 2015-11-25

Type: CWE-79

Risk Information

CVSS v2

Base Score: 2.1

Vector: AV:N/AC:H/Au:S/C:N/I:P/A:N

Impact Score: 2.9

Exploitability Score: 3.9

Severity: LOW

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:wordpress:wordpress:3.0:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.0.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.0.2:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.0.3:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.0.4:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.0.5:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.0.6:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.1.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.1.2:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.1.3:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.1.4:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.2:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.2:beta1:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.2.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.3:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.3.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.3.2:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.3.3:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.4.0:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.4.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.4.2:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.5.0:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.5.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.6:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.6.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.7:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.7.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.8:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.8.1:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:3.9.0:*:*:*:*:*:*:*

cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* versions up to 3.9.1 (inclusive)

Configuration 2

OR

cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*

Tenable Plugins

View all (6 total)

IDNameProductFamilySeverity
9025WordPress < 3.7.4 / 3.8.x < 3.8.4 / 3.9.x < 3.9.2 Multiple VulnerabilitiesNessus Network MonitorCGI
high
82202Debian DLA-56-1 : wordpress security updateNessusDebian Local Security Checks
high
77347Fedora 19 : wordpress-3.9.2-3.fc19 (2014-9270)NessusFedora Local Security Checks
high
77312Fedora 20 : wordpress-3.9.2-3.fc20 (2014-9264)NessusFedora Local Security Checks
high
77157WordPress < 3.7.4 / 3.8.4 / 3.9.2 Multiple VulnerabilitiesNessusCGI abuses
high
77102Debian DSA-3001-1 : wordpress - security updateNessusDebian Local Security Checks
high