Oracle MySQL Server 5.5.x <= 5.5.26 / 5.1.x <= 5.1.64 Multiple Unspecified Vulnerabilities

High Nessus Network Monitor Plugin ID 6610

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.27. As such, it is reportedly affected by the following vulnerabilities:

- An exploitable vulnerability which allows successful authenticated network attacks via multiple protocols. In some cases it can cause a Denial-of-Service or result in execution of arbitrary code.

Solution

Upgrade to MySQL Server 5.5.27 / 5.1.65 later.

See Also

http://www.oracle.com/technetwork/topics/security/cpuoct2012-1515893.html

http://www.oracle.com/technetwork/topics/security/cpuoct2012verbose-1515934.html

Plugin Details

Severity: High

ID: 6610

Family: Database

Published: 2012/10/19

Modified: 2016/02/05

Dependencies: 8914

Nessus ID: 62638, 62641

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 6.7

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.7

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2012/10/16

Vulnerability Publication Date: 2012/10/16

Reference Information

CVE: CVE-2012-3144, CVE-2012-3147, CVE-2012-3149, CVE-2012-3150, CVE-2012-3158, CVE-2012-3163, CVE-2012-3197

BID: 55990, 56006, 56008, 56017, 56021, 56022, 56036