MySQL 5.1 < 5.1.65 Multiple Vulnerabilities

high Nessus Plugin ID 62638


The remote database server is affected by multiple vulnerabilities.


The version of MySQL 5.1 installed on the remote host is earlier than 5.1.65 and is, therefore, affected by vulnerabilities in the following components :

- Information Schema
- Protocol
- Server Optimizer
- Server Replication


Upgrade to MySQL version 5.1.65 or later.

See Also

Plugin Details

Severity: High

ID: 62638

File Name: mysql_5_1_65.nasl

Version: 1.8

Type: remote

Family: Databases

Published: 10/19/2012

Updated: 11/15/2018

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/16/2012

Vulnerability Publication Date: 10/16/2012

Reference Information

CVE: CVE-2012-3150, CVE-2012-3158, CVE-2012-3163, CVE-2012-3197

BID: 55990, 56017, 56036, 56021