MySQL 5.5 < 5.5.27 Multiple Vulnerabilities

high Nessus Plugin ID 62641
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.27 and is, therefore, affected by vulnerabilities in the following components :

- Information Schema
- MySQL Client
- Protocol
- Server
- Server Optimizer
- Server Replication

Solution

Upgrade to MySQL version 5.5.27 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-27.html

http://www.nessus.org/u?87547c81

Plugin Details

Severity: High

ID: 62641

File Name: mysql_5_5_27.nasl

Version: 1.8

Type: remote

Family: Databases

Published: 10/19/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9

Temporal Score: 6.7

Vector: AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 10/16/2012

Vulnerability Publication Date: 10/16/2012

Reference Information

CVE: CVE-2012-3144, CVE-2012-3147, CVE-2012-3149, CVE-2012-3150, CVE-2012-3158, CVE-2012-3163, CVE-2012-3197

BID: 55990, 56006, 56008, 56017, 56021, 56022, 56036