PHP < 4.3.10 / 5.0.3 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 2460


The remote host is vulnerable to a script injection attack.


The remote host is running a version of PHP which is older than 5.0.3 or 4.3.10.
The remote version of this software is vulnerable to various security issues that may, under certain circumstances, allow attackers to execute arbitrary code on the remote host, provided that they can pass arbitrary data to some functions or bypass safe_mode.


Upgrade to PHP 5.0.3 or 4.3.10 or higher.

See Also

Plugin Details

Severity: Critical

ID: 2460

Family: Web Servers

Published: 2004/12/10

Updated: 2019/03/06

Dependencies: 8728, 8682

Nessus ID: 15973

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2004/11/23

Vulnerability Publication Date: 2004/11/23

Reference Information

CVE: CVE-2004-1018, CVE-2004-1019, CVE-2004-1020, CVE-2004-1063, CVE-2004-1064, CVE-2004-1065

BID: 11981, 11992, 12045, 11964