PHP < 4.3.10 / 5.0.3 Multiple Vulnerabilities

high Nessus Plugin ID 15973
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is prior to 4.3.10 / 5.0.3. It is, therefore, affected by multiple security issues that could, under certain circumstances, allow an attacker to execute arbitrary code on the remote host, provided that the attacker can pass arbitrary data to some functions, or to bypass safe_mode.

Solution

Upgrade to PHP 5.0.3 or 4.3.10.

See Also

http://www.php.net/ChangeLog-5.php#5.0.3

Plugin Details

Severity: High

ID: 15973

File Name: php45_multiple_flaws.nasl

Version: 1.24

Type: remote

Family: CGI abuses

Published: 12/15/2004

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.8

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 12/14/2004

Vulnerability Publication Date: 11/23/2004

Reference Information

CVE: CVE-2004-1018, CVE-2004-1019, CVE-2004-1020, CVE-2004-1063, CVE-2004-1064, CVE-2004-1065

BID: 11964, 11981, 11992, 12045

CWE: 20