CVE-2004-1019

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The deserialization code in PHP before 4.3.10 and PHP 5.x up to 5.0.2 allows remote attackers to cause a denial of service and execute arbitrary code via untrusted data to the unserialize function that may trigger "information disclosure, double-free and negative reference index array underflow" results.

References

http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00029.html

http://lists.opensuse.org/opensuse-updates/2015-02/msg00079.html

http://marc.info/?l=bugtraq&m=110314318531298&w=2

http://msgs.securepoint.com/cgi-bin/get/bugtraq0412/157.html

http://www.hardened-php.net/advisories/012004.txt

http://www.mandriva.com/security/advisories?name=MDKSA-2004:151

http://www.novell.com/linux/security/advisories/2005_02_php4_mod_php4.html

http://www.oracle.com/technetwork/topics/security/bulletinjan2015-2370101.html

http://www.php.net/release_4_3_10.php

http://www.redhat.com/support/errata/RHSA-2004-687.html

http://www.redhat.com/support/errata/RHSA-2005-032.html

http://www.redhat.com/support/errata/RHSA-2005-816.html

http://www.securityfocus.com/advisories/9028

https://bugzilla.fedora.us/show_bug.cgi?id=2344

https://exchange.xforce.ibmcloud.com/vulnerabilities/18514

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10511

Details

Source: MITRE

Published: 2005-01-10

Updated: 2018-10-30

Type: CWE-20

Risk Information

CVSS v2

Base Score: 10

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Impact Score: 10

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:openpkg:openpkg:2.1:*:*:*:*:*:*:*

cpe:2.3:a:openpkg:openpkg:2.2:*:*:*:*:*:*:*

cpe:2.3:a:openpkg:openpkg:current:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.6:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.7:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.8:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.9:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.10:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.11:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.12:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.13:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.14:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.15:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.16:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.17:*:*:*:*:*:*:*

cpe:2.3:a:php:php:3.0.18:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.1:patch1:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.1:patch2:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.3:patch1:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.6:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.7:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.7:rc1:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.7:rc2:*:*:*:*:*:*

cpe:2.3:a:php:php:4.0.7:rc3:*:*:*:*:*:*

cpe:2.3:a:php:php:4.1.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.1.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.1.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.2:*:dev:*:*:*:*:*

cpe:2.3:a:php:php:4.2.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.2.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.2.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.2.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.2:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.3:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.4:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.5:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.6:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.7:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.8:*:*:*:*:*:*:*

cpe:2.3:a:php:php:4.3.9:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.0:rc1:*:*:*:*:*:*

cpe:2.3:a:php:php:5.0:rc2:*:*:*:*:*:*

cpe:2.3:a:php:php:5.0:rc3:*:*:*:*:*:*

cpe:2.3:a:php:php:5.0.0:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.0.1:*:*:*:*:*:*:*

cpe:2.3:a:php:php:5.0.2:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:o:trustix:secure_linux:2.0:*:*:*:*:*:*:*

cpe:2.3:o:trustix:secure_linux:2.1:*:*:*:*:*:*:*

cpe:2.3:o:trustix:secure_linux:2.2:*:*:*:*:*:*:*

cpe:2.3:o:ubuntu:ubuntu_linux:4.1:*:ia64:*:*:*:*:*

cpe:2.3:o:ubuntu:ubuntu_linux:4.1:*:ppc:*:*:*:*:*

Tenable Plugins

View all (18 total)

IDNameProductFamilySeverity
119961SUSE SLES12 Security Update : php5 (SUSE-SU-2015:0365-1)NessusSuSE Local Security Checks
critical
93161SUSE SLES11 Security Update : php53 (SUSE-SU-2016:1638-1) (BACKRONYM)NessusSuSE Local Security Checks
critical
81418openSUSE Security Update : php5 (openSUSE-2015-163)NessusSuSE Local Security Checks
critical
20657Ubuntu 4.10 : php4 vulnerabilities (USN-40-1)NessusUbuntu Local Security Checks
critical
20207RHEL 2.1 : php (RHSA-2005:838)NessusRed Hat Local Security Checks
critical
19133FreeBSD : php -- multiple vulnerabilities (d47e9d19-5016-11d9-9b5f-0050569f0001)NessusFreeBSD Local Security Checks
critical
17166RHEL 4 : php (RHSA-2005:032)NessusRed Hat Local Security Checks
critical
16306SUSE-SA:2005:002: php4, mod_php4NessusSuSE Local Security Checks
critical
2555Mac OS X Multiple Vulnerabilities (Security Update 2005-001)Nessus Network MonitorWeb Clients
critical
16251Mac OS X Multiple Vulnerabilities (Security Update 2005-001)NessusMacOS X Local Security Checks
high
16222RHEL 2.1 : php (RHSA-2005:031)NessusRed Hat Local Security Checks
critical
16041RHEL 3 : php (RHSA-2004:687)NessusRed Hat Local Security Checks
critical
16001GLSA-200412-14 : PHP: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
15998Mandrake Linux Security Advisory : php (MDKSA-2004:151)NessusMandriva Local Security Checks
critical
15973PHP < 4.3.10 / 5.0.3 Multiple VulnerabilitiesNessusCGI abuses
high
2460PHP < 4.3.10 / 5.0.3 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
801104PHP < 4.3.10 / 5.0.3 Multiple VulnerabilitiesLog Correlation EngineWeb Servers
high
800804Mac OS X Multiple Vulnerabilities (Security Update 2005-001)Log Correlation EngineOperating System Detection
high